summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-02 12:19:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-02 12:19:23 +0100
commitfd2fce14c2b61e2baac6feff9be545c4940f09f4 (patch)
treeb66307049d7b1fe69a3dc6afa297294c864231c8 /net-misc/dhcp/files
parentdev-vcs/mercurial: Removed old. (diff)
downloadgentoo-fd2fce14c2b61e2baac6feff9be545c4940f09f4.tar.gz
gentoo-fd2fce14c2b61e2baac6feff9be545c4940f09f4.tar.bz2
gentoo-fd2fce14c2b61e2baac6feff9be545c4940f09f4.zip
net-misc/dhcp: Bump to version 4.4.0
Package-Manager: Portage-2.3.23, Repoman-2.3.6
Diffstat (limited to 'net-misc/dhcp/files')
-rw-r--r--net-misc/dhcp/files/dhcp-4.4.0-always-accept-4.patch29
-rw-r--r--net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch22
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/dhcp/files/dhcp-4.4.0-always-accept-4.patch b/net-misc/dhcp/files/dhcp-4.4.0-always-accept-4.patch
new file mode 100644
index 000000000000..bbb25eb194bd
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp-4.4.0-always-accept-4.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/437108
+
+Always accept the -4 option even if we don't have IPv6 support enabled.
+The relay code does this already.
+
+--- dhcp-4.4.0/client/dhclient.c
++++ dhcp-4.4.0/client/dhclient.c
+@@ -353,8 +353,8 @@
+ if (!strcmp(argv[i], "-r")) {
+ release_mode = 1;
+ /* no_daemon = 1; */
+-#ifdef DHCPv6
+ } else if (!strcmp(argv[i], "-4")) {
++#ifdef DHCPv6
+ if (local_family_set && local_family != AF_INET)
+ log_fatal("Client can only do v4 or v6, not "
+ "both.");
+--- dhcp-4.4.0/server/dhcpd.c
++++ dhcp-4.4.0/server/dhcpd.c
+@@ -495,8 +495,8 @@
+ } else if (!strcmp (argv [i], "-q")) {
+ quiet = 1;
+ quiet_interface_discovery = 1;
+-#ifdef DHCPv6
+ } else if (!strcmp(argv[i], "-4")) {
++#ifdef DHCPv6
+ if (local_family_set && (local_family != AF_INET)) {
+ log_fatal("Server cannot run in both IPv4 and "
+ "IPv6 mode at the same time.");
diff --git a/net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch b/net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch
new file mode 100644
index 000000000000..b74255ca4e97
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch
@@ -0,0 +1,22 @@
+--- dhcp-4.4.0/bind/Makefile.in
++++ dhcp-4.4.0/bind/Makefile.in
+@@ -37,6 +37,7 @@
+ @BIND_ATF_TRUE@all: bind1 atf bind2
+
+ bind1:
++disable:
+ # Extract the source from the tarball, if it hasn't been already.
+ @if test -d ${bindsrcdir} ; then \
+ echo ${bindsrcdir} already unpacked... ; \
+@@ -60,6 +61,7 @@
+ fi
+
+ atf:
++disable:
+ # Build and copy the ATF support if not yet installed.
+ @if test -d ./atf ; then \
+ echo ATF support already installed ; \
+--- dhcp-4.4.0/bind/test
++++ dhcp-4.4.0/bind/test
+@@ -0,0 +1 @@
++--disable-kqueue --disable-epoll --disable-devpoll --without-openssl --without-libxml2 --enable-exportlib --with-gssapi=no --enable-threads=no @BINDCONFIG@ --includedir=${binddir}/include --libdir=${binddir}/lib