summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-15 09:02:53 +0000
committerSam James <sam@gentoo.org>2022-11-15 09:05:49 +0000
commit8628153ddde353e830573c4569c99f9c23ea6eb1 (patch)
treea727092595b75cfb6ba27957cdc1bb614bceda50 /net-misc/dropbear/files/dropbear-2022.82-tests.patch
parentdev-vcs/pre-commit: drop ebuilds depending on dev-python/toml (diff)
downloadgentoo-8628153ddde353e830573c4569c99f9c23ea6eb1.tar.gz
gentoo-8628153ddde353e830573c4569c99f9c23ea6eb1.tar.bz2
gentoo-8628153ddde353e830573c4569c99f9c23ea6eb1.zip
net-misc/dropbear: work towards fixing tests
Restrict for now as they end up wanting interactive input. Closes: https://bugs.gentoo.org/836990 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/dropbear/files/dropbear-2022.82-tests.patch')
-rw-r--r--net-misc/dropbear/files/dropbear-2022.82-tests.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/dropbear/files/dropbear-2022.82-tests.patch b/net-misc/dropbear/files/dropbear-2022.82-tests.patch
new file mode 100644
index 000000000000..6619e6c07551
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-2022.82-tests.patch
@@ -0,0 +1,25 @@
+--- a/test/Makefile.in
++++ b/test/Makefile.in
+@@ -4,18 +4,13 @@ SHELL=bash
+
+ all: test
+
+-test: venv/bin/pytest fakekey
+- (source ./venv/bin/activate; pytest --hostkey=fakekey --dbclient=../dbclient --dropbear=../dropbear $(srcdir) )
++test: fakekey
++ pytest --hostkey=fakekey --dbclient=../dbclient --dropbear=../dropbear $(srcdir)
+
+-one: venv/bin/pytest fakekey
+- (source ./venv/bin/activate; pytest --hostkey=fakekey --dbclient=../dbclient --dropbear=../dropbear $(srcdir) -k exit)
++one: fakekey
++ pytest --hostkey=fakekey --dbclient=../dbclient --dropbear=../dropbear $(srcdir) -k exit
+
+ fakekey:
+ ../dropbearkey -t ecdsa -f $@
+
+-venv/bin/pytest: $(srcdir)/requirements.txt
+- python3 -m venv init venv
+- ./venv/bin/pip install --upgrade pip
+- ./venv/bin/pip install -r $(srcdir)/requirements.txt
+-
+ .PHONY: test