summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-04-24 21:18:14 -0700
committerZac Medico <zmedico@gentoo.org>2019-04-24 21:26:34 -0700
commit0b9196e0375c2e24ad585a05791f585c63598e98 (patch)
treeae9c1f11d69e43afe71635432e2a68e6dcc3e9e6 /net-misc/electron-cash/files
parentdev-ruby/selenium-webdriver: fix childprocess dependency (diff)
downloadgentoo-0b9196e0375c2e24ad585a05791f585c63598e98.tar.gz
gentoo-0b9196e0375c2e24ad585a05791f585c63598e98.tar.bz2
gentoo-0b9196e0375c2e24ad585a05791f585c63598e98.zip
net-misc/electron-cash: version bump to 3.3.6
Reported-by: Kete Tefid <ketetefid@gmail.com> Closes: https://bugs.gentoo.org/670070 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc/electron-cash/files')
-rw-r--r--net-misc/electron-cash/files/3.3.6-no-user-root.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/electron-cash/files/3.3.6-no-user-root.patch b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
new file mode 100644
index 000000000000..f5f0aecf382f
--- /dev/null
+++ b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
@@ -0,0 +1,27 @@
+--- a/setup.py
++++ b/setup.py
+@@ -33,23 +33,7 @@
+ # Use per-user */share directory if the global one is not writable or if a per-user installation
+ # is attempted
+ user_share = os.environ.get('XDG_DATA_HOME', os.path.expanduser('~/.local/share'))
+- system_share = os.path.join(opts.prefix_path, "share")
+- if not opts.is_user:
+- # Not neccarily a per-user installation try system directories
+- if os.access(opts.root_path + system_share, os.W_OK):
+- # Global /usr/share is writable for us – so just use that
+- share_dir = system_share
+- elif not os.path.exists(opts.root_path + system_share) and os.access(opts.root_path, os.W_OK):
+- # Global /usr/share does not exist, but / is writable – keep using the global directory
+- # (happens during packaging)
+- share_dir = system_share
+- else:
+- # Neither /usr/share (nor / if /usr/share doesn't exist) is writable, use the
+- # per-user */share directory
+- share_dir = user_share
+- else:
+- # Per-user installation
+- share_dir = user_share
++ share_dir = os.path.join(opts.prefix_path, "share")
+ data_files += [
+ # Menu icon
+ # Menu entry