summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-19 18:15:57 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-19 18:15:57 -0700
commitcf95a138451d35566712e45ae763c0470ea2254e (patch)
treef4ba3546c01fb45f4c07f720ec143b8880b91fa9 /net-misc/exabgp/exabgp-3.4.28-r2.ebuild
parentacct-user/exabgp: New package (diff)
downloadgentoo-cf95a138451d35566712e45ae763c0470ea2254e.tar.gz
gentoo-cf95a138451d35566712e45ae763c0470ea2254e.tar.bz2
gentoo-cf95a138451d35566712e45ae763c0470ea2254e.zip
net-misc/exabgp: revbumps, add deps on user/group packages
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc/exabgp/exabgp-3.4.28-r2.ebuild')
-rw-r--r--net-misc/exabgp/exabgp-3.4.28-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/exabgp/exabgp-3.4.28-r2.ebuild b/net-misc/exabgp/exabgp-3.4.28-r2.ebuild
new file mode 100644
index 000000000000..f6753117ebc7
--- /dev/null
+++ b/net-misc/exabgp/exabgp-3.4.28-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit tmpfiles systemd distutils-r1
+
+DESCRIPTION="The BGP swiss army knife of networking"
+HOMEPAGE="https://github.com/Exa-Networks/exabgp"
+SRC_URI="https://github.com/Exa-Networks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/exabgp
+ acct-user/exabgp
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ newtmpfiles "${FILESDIR}/exabgp.tmpfiles" ${PN}.conf
+ systemd_dounit etc/systemd/*
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ keepdir /etc/exabgp
+}