summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-06-28 11:28:27 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-06-28 11:28:27 -0700
commitf37b90eb56d8feaea353a29379c14f3898bf1386 (patch)
tree2689e8510f7f6998a87eb3ed98554d829e0e70e8 /net-misc/exabgp
parentapp-admin/salt: drop versions (diff)
downloadgentoo-f37b90eb56d8feaea353a29379c14f3898bf1386.tar.gz
gentoo-f37b90eb56d8feaea353a29379c14f3898bf1386.tar.bz2
gentoo-f37b90eb56d8feaea353a29379c14f3898bf1386.zip
net-misc/exabgp: add 4.2.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc/exabgp')
-rw-r--r--net-misc/exabgp/Manifest1
-rw-r--r--net-misc/exabgp/exabgp-4.2.20.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/exabgp/Manifest b/net-misc/exabgp/Manifest
index 874fa190a959..08bf07c092be 100644
--- a/net-misc/exabgp/Manifest
+++ b/net-misc/exabgp/Manifest
@@ -2,3 +2,4 @@ DIST exabgp-4.2.11.tar.gz 2931753 BLAKE2B e5241619db24e2e82dfb42bc613d6b2c28efac
DIST exabgp-4.2.16.tar.gz 2933071 BLAKE2B bc66ece537cb175811233d26f3445e1bb3f7d4f8950bf0839ced014430db17a4df614661448f275fb3a890bb2af6b2459f938f830c82f03a586829e7fe31caca SHA512 06731612df6f0f6623e8ad58c3b52fc4b5dee6b4bb3bb29cee272a4061ef087e2f98739a75cd07ae51e66fb633069926899882e6bab801010ad1db3333666471
DIST exabgp-4.2.17.tar.gz 2933104 BLAKE2B 5751888232479c24aa4f66ef357821178c7a5564c0522adb8abf26057eb222ecfbb33caa6d9b71219b79fa309a0c4051b6098015c2362ad9c02e59326ee2bfac SHA512 2000856f540dcaed12dfaf54b689f6b04670f0ec8f19ec7a811ea8e54663afec68a7ae97ed79a001cc09ed42e6a1c5bd2d94ae0c3e3c8bde2da446cf00d66374
DIST exabgp-4.2.19.tar.gz 2932903 BLAKE2B de988dca0d6c32dbe5a5a04a2f3b5065a71ec83aabccecf675ddf09f9bd38ee417b670c5a2940d12bf3618a9a39e8ec6d0184bfa77cfda8c5e853da0fd52bda4 SHA512 35031fbf1b73339926dd08c7edc80497c3a5c4d1a5d626bf2a704ad2e70baeca51a88fe56fe3e43b97187010cf7e89c2b69f0b28276bbf9a945e761c6578818f
+DIST exabgp-4.2.20.tar.gz 2933683 BLAKE2B 8d25442dd3e95ad6db2849adb2ba04563c9c2add50fe94993cc1d72f17c704118732c1a8b88cec48f4a5c3b3f186c66b6643d3d06543475a43f0630801394006 SHA512 39de1baa9a4abee9829b3dea211966ec58e487f26c7f9d0d0cd19f5fcca596c9d3a389073bcb19506924feb7af34f4ffc6cbf13b7471cf5e51857af35271e6a5
diff --git a/net-misc/exabgp/exabgp-4.2.20.ebuild b/net-misc/exabgp/exabgp-4.2.20.ebuild
new file mode 100644
index 000000000000..c6fbf314f463
--- /dev/null
+++ b/net-misc/exabgp/exabgp-4.2.20.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit tmpfiles systemd distutils-r1
+
+DESCRIPTION="The BGP swiss army knife of networking"
+HOMEPAGE="https://github.com/Exa-Networks/exabgp"
+SRC_URI="https://github.com/Exa-Networks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/exabgp
+ acct-user/exabgp
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/exabgp-4.2.7-paths.patch"
+ "${FILESDIR}/exabgp-4.2.10-ip-path.patch"
+ "${FILESDIR}/exabgp-4.2.11-healthcheck-allow-disable-metric.patch"
+ "${FILESDIR}/exabgp-4.2.11-healthcheck-fix-log-crash.patch"
+ "${FILESDIR}/exabgp-4.2.11-less-verbose-logging.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ ./qa/bin/parsing || die "tests fail with ${EPYTHON}"
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ newtmpfiles "${FILESDIR}/exabgp.tmpfiles" ${PN}.conf
+ systemd_dounit etc/systemd/*
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ keepdir /etc/exabgp
+
+ doman doc/man/*.?
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}