summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-29 18:19:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-03-29 18:19:30 +0200
commit4015d229e7fc42f4550cd8e0132fc8b257a44859 (patch)
tree87604f59e24d6b67387bed5cd5817217129afc5b /net-misc/freelan/files
parentnet-fs/samba: Make pam dependency optional again (bug #489770). (diff)
downloadgentoo-4015d229e7fc42f4550cd8e0132fc8b257a44859.tar.gz
gentoo-4015d229e7fc42f4550cd8e0132fc8b257a44859.tar.bz2
gentoo-4015d229e7fc42f4550cd8e0132fc8b257a44859.zip
net-misc/freelan: initial import; ebuild by me
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'net-misc/freelan/files')
-rw-r--r--net-misc/freelan/files/boost158.patch41
-rw-r--r--net-misc/freelan/files/mf.patch33
-rw-r--r--net-misc/freelan/files/prefix.patch81
3 files changed, 155 insertions, 0 deletions
diff --git a/net-misc/freelan/files/boost158.patch b/net-misc/freelan/files/boost158.patch
new file mode 100644
index 000000000000..7d5bb740f7bd
--- /dev/null
+++ b/net-misc/freelan/files/boost158.patch
@@ -0,0 +1,41 @@
+commit 68d18a5a7dd7fad8638409d46d144d33a30b54ce
+Author: Mihai Bişog <mihai.bisog@gmail.com>
+Date: Sat Aug 1 15:18:35 2015 +0300
+
+ Fixed compilation errors when compiling against boost 1.58
+
+diff --git a/libs/asiotap/include/asiotap/types/endpoint.hpp b/libs/asiotap/include/asiotap/types/endpoint.hpp
+index 125e1b4..318b7e6 100644
+--- a/libs/asiotap/include/asiotap/types/endpoint.hpp
++++ b/libs/asiotap/include/asiotap/types/endpoint.hpp
+@@ -350,6 +350,9 @@ namespace asiotap
+ */
+ std::istream& operator>>(std::istream& is, endpoint& value);
+
++// Note: this operator is defined in boost variant as of version 1.58. Keeping it around will
++// introduce overload resolution ambiguity.
++#if BOOST_VERSION < 105800
+ /**
+ * \brief Compare two endpoints.
+ * \param lhs The left argument.
+@@ -360,6 +363,7 @@ namespace asiotap
+ {
+ return !(lhs == rhs);
+ }
++#endif
+
+ /**
+ * \brief Get an endpoint with a default port.
+diff --git a/libs/freelan/src/curl.cpp b/libs/freelan/src/curl.cpp
+index 342bb79..392d734 100644
+--- a/libs/freelan/src/curl.cpp
++++ b/libs/freelan/src/curl.cpp
+@@ -146,7 +146,7 @@ namespace freelan
+
+ void curl::set_proxy(const asiotap::endpoint& proxy)
+ {
+- if (proxy != asiotap::hostname_endpoint::null())
++ if (proxy != asiotap::endpoint(asiotap::hostname_endpoint::null()))
+ {
+ set_option(CURLOPT_PROXY, static_cast<const void*>(boost::lexical_cast<std::string>(proxy).c_str()));
+ }
diff --git a/net-misc/freelan/files/mf.patch b/net-misc/freelan/files/mf.patch
new file mode 100644
index 000000000000..c7e169f4e8a7
--- /dev/null
+++ b/net-misc/freelan/files/mf.patch
@@ -0,0 +1,33 @@
+commit 4109bb053906f45b545a6cca4399734b91bca425
+Author: Julien Kauffmann <julien.kauffmann@freelan.org>
+Date: Sat May 9 16:55:51 2015 -0400
+
+ Fixed Makefile
+
+diff --git a/Makefile b/Makefile
+index d6bcd59..20b5ea1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,15 @@
+ PRODUCT_NAME:=freelan
+-PRODUCT_VERSION:=$(shell git describe)
++PRODUCT_VERSION:=$(shell cat VERSION | tr -d '\r\n')
++PRODUCT_PREFIX=/usr
+
+-default: install
+-
+-install:
+- # Install the files to ${DESTDIR} (defaults to /)
+- scons install prefix=/
++default: build
+
+ build:
+- scons all samples
++ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} scons --mode=release apps prefix=${PRODUCT_PREFIX}
++
++install:
++ # Install the files to $(DESTDIR) (defaults to /)
++ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} DESTDIR=$(DESTDIR) scons --mode=release install prefix=${PRODUCT_PREFIX}
+
+ package:
+ git archive HEAD --prefix=${PRODUCT_NAME}-${PRODUCT_VERSION}/ | gzip > ${PRODUCT_NAME}-${PRODUCT_VERSION}.tar.gz
diff --git a/net-misc/freelan/files/prefix.patch b/net-misc/freelan/files/prefix.patch
new file mode 100644
index 000000000000..ac75e87fb1d1
--- /dev/null
+++ b/net-misc/freelan/files/prefix.patch
@@ -0,0 +1,81 @@
+commit d782a42eaeecdce9b4377a7b41dc60b9fecca31c
+Author: Julien Kauffmann <julien.kauffmann@freelan.org>
+Date: Sat May 9 19:30:11 2015 -0400
+
+ Added support for a different binary prefix
+
+diff --git a/Makefile b/Makefile
+index 20b5ea1..b009d2c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,16 @@
+ PRODUCT_NAME:=freelan
+ PRODUCT_VERSION:=$(shell cat VERSION | tr -d '\r\n')
+-PRODUCT_PREFIX=/usr
++PRODUCT_BIN_PREFIX=/usr
++PRODUCT_PREFIX=/
+
+ default: build
+
+ build:
+- FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} scons --mode=release apps prefix=${PRODUCT_PREFIX}
++ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} scons --mode=release apps prefix=${PRODUCT_PREFIX} bin_prefix=${PRODUCT_BIN_PREFIX}
+
+ install:
+ # Install the files to $(DESTDIR) (defaults to /)
+- FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} DESTDIR=$(DESTDIR) scons --mode=release install prefix=${PRODUCT_PREFIX}
++ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} DESTDIR=$(DESTDIR) scons --mode=release install prefix=${PRODUCT_PREFIX} bin_prefix=${PRODUCT_BIN_PREFIX}
+
+ package:
+ git archive HEAD --prefix=${PRODUCT_NAME}-${PRODUCT_VERSION}/ | gzip > ${PRODUCT_NAME}-${PRODUCT_VERSION}.tar.gz
+diff --git a/SConstruct b/SConstruct
+index 32a9915..bc68b71 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -28,7 +28,7 @@ class FreelanEnvironment(Environment):
+ A freelan specific environment class.
+ """
+
+- def __init__(self, mode, prefix, **kwargs):
++ def __init__(self, mode, prefix, bin_prefix=None, **kwargs):
+ """
+ Initialize the environment.
+
+@@ -66,14 +66,19 @@ class FreelanEnvironment(Environment):
+
+ self.mode = mode
+ self.prefix = prefix
++ self.bin_prefix = bin_prefix if bin_prefix else prefix
+ self.destdir = self['ENV'].get('DESTDIR', '')
+
+ if self.destdir:
+ self.install_prefix = os.path.normpath(
+ os.path.abspath(self.destdir),
+ ) + self.prefix
++ self.bin_install_prefix = os.path.normpath(
++ os.path.abspath(self.destdir),
++ ) + self.bin_prefix
+ else:
+ self.install_prefix = self.prefix
++ self.bin_install_prefix = self.bin_prefix
+
+ if os.path.basename(self['CXX']) == 'clang++':
+ self.Append(CXXFLAGS=['-Qunused-arguments'])
+@@ -147,10 +152,15 @@ class FreelanEnvironment(Environment):
+ mode = GetOption('mode')
+ prefix = os.path.normpath(os.path.abspath(ARGUMENTS.get('prefix', './install')))
+
++if 'bin_prefix' in ARGUMENTS:
++ bin_prefix = os.path.normpath(os.path.abspath(ARGUMENTS['bin_prefix']))
++else:
++ bin_prefix = None
++
+ if mode in ('all', 'release'):
+- env = FreelanEnvironment(mode='release', prefix=prefix)
++ env = FreelanEnvironment(mode='release', prefix=prefix, bin_prefix=bin_prefix)
+ libraries, includes, apps, samples, configurations = SConscript('SConscript', exports='env', variant_dir=os.path.join('build', env.mode))
+- install = env.Install(os.path.join(env.install_prefix, 'bin'), apps)
++ install = env.Install(os.path.join(env.bin_install_prefix, 'bin'), apps)
+ install.extend(env.Install(os.path.join(env.install_prefix, 'etc', 'freelan'), configurations))
+
+ Alias('install', install)