summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-29 18:19:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-03-29 18:19:30 +0200
commit4015d229e7fc42f4550cd8e0132fc8b257a44859 (patch)
tree87604f59e24d6b67387bed5cd5817217129afc5b /net-misc/freelan/freelan-2.0.ebuild
parentnet-fs/samba: Make pam dependency optional again (bug #489770). (diff)
downloadgentoo-4015d229e7fc42f4550cd8e0132fc8b257a44859.tar.gz
gentoo-4015d229e7fc42f4550cd8e0132fc8b257a44859.tar.bz2
gentoo-4015d229e7fc42f4550cd8e0132fc8b257a44859.zip
net-misc/freelan: initial import; ebuild by me
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'net-misc/freelan/freelan-2.0.ebuild')
-rw-r--r--net-misc/freelan/freelan-2.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/freelan/freelan-2.0.ebuild b/net-misc/freelan/freelan-2.0.ebuild
new file mode 100644
index 000000000000..c8d8d4948600
--- /dev/null
+++ b/net-misc/freelan/freelan-2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit scons-utils toolchain-funcs eutils
+
+DESCRIPTION="Peer-to-peer VPN software that abstracts a LAN over the Internet"
+HOMEPAGE="http://www.freelan.org/"
+SRC_URI="https://github.com/freelan-developers/freelan/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/boost:=[threads]
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ virtual/libiconv
+"
+RDEPEND="${DEPEND}"
+
+FREELAN_NO_GIT=1
+FREELAN_NO_GIT_VERSION=${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/boost158.patch" \
+ "${FILESDIR}/mf.patch" \
+ "${FILESDIR}/prefix.patch"
+
+ sed -e "s/CXXFLAGS='-O3'/CXXFLAGS=''/" \
+ -e "s/CXXFLAGS=\['-Werror'\]/CXXFLAGS=[]/" \
+ -e "s/CXXFLAGS=\['-pedantic'\]/CXXFLAGS=[]/" \
+ -i SConstruct || die
+ epatch_user
+}
+
+src_compile() {
+ tc-export CXX CC AR
+ export LINK="$(tc-getCXX)"
+
+ local MYSCONS=(
+ "--mode=$(usex debug debug release)"
+ prefix="${EPREFIX:-/}"
+ bin_prefix="/usr"
+ apps
+ )
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ DESTDIR="${D}" escons --mode=release prefix="${EPREFIX:-/}" bin_prefix="/usr" install
+ dodoc CONTRIBUTING.md README.md
+}