summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-01-08 13:37:34 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-01-08 13:37:50 -0700
commit34a03c3521981139d17b0d6d0d87c515a8830aa5 (patch)
tree1def2f2eca8bfdee4f953789c6683b6c86df88d2 /net-misc/grive/grive-0.5.1_pre20161004.ebuild
parentgnome-extra/cinnamon-screensaver: 3.2.13 (diff)
downloadgentoo-34a03c3521981139d17b0d6d0d87c515a8830aa5.tar.gz
gentoo-34a03c3521981139d17b0d6d0d87c515a8830aa5.tar.bz2
gentoo-34a03c3521981139d17b0d6d0d87c515a8830aa5.zip
net-misc/grive: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/grive/grive-0.5.1_pre20161004.ebuild')
-rw-r--r--net-misc/grive/grive-0.5.1_pre20161004.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/grive/grive-0.5.1_pre20161004.ebuild b/net-misc/grive/grive-0.5.1_pre20161004.ebuild
new file mode 100644
index 000000000000..3d31fa6dc756
--- /dev/null
+++ b/net-misc/grive/grive-0.5.1_pre20161004.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/vitalif/${PN}2.git"
+else
+ inherit vcs-snapshot
+ COMMIT="7bbb01c3014cc996ec24a7e5c0684f24b604b735"
+ SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-libs/json-c-0.11-r1:=
+ dev-libs/libgcrypt:0=
+ || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
+ sys-libs/binutils-libs:0=
+ sys-libs/glibc
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"