summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-09-27 08:19:56 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-09-27 08:20:17 -0600
commit9130c8b50f2b515a096f42a7ff39f1a2764d5e38 (patch)
treed667ff185702fddf78a12284e0866ee4c2612591 /net-misc/grive/grive-0.5.2_pre20200205.ebuild
parentapp-admin/mongo-tools: Stabilize 4.2.8 amd64, #735276 (diff)
downloadgentoo-9130c8b50f2b515a096f42a7ff39f1a2764d5e38.tar.gz
gentoo-9130c8b50f2b515a096f42a7ff39f1a2764d5e38.tar.bz2
gentoo-9130c8b50f2b515a096f42a7ff39f1a2764d5e38.zip
net-misc/grive: version bump
Bug: https://bugs.gentoo.org/744892 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'net-misc/grive/grive-0.5.2_pre20200205.ebuild')
-rw-r--r--net-misc/grive/grive-0.5.2_pre20200205.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/grive/grive-0.5.2_pre20200205.ebuild b/net-misc/grive/grive-0.5.2_pre20200205.ebuild
new file mode 100644
index 000000000000..fdaaf8147839
--- /dev/null
+++ b/net-misc/grive/grive-0.5.2_pre20200205.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
+else
+ inherit vcs-snapshot
+ COMMIT="ffb744a59b1496f86ec71581345355715d846f7b"
+ SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-libs/json-c-0.11-r1:=
+ dev-libs/libgcrypt:0=
+ dev-libs/yajl
+ || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
+ sys-libs/binutils-libs:0=
+ sys-libs/glibc
+"
+DEPEND="${RDEPEND}"