summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/guacamole-server/guacamole-server-0.8.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/guacamole-server/guacamole-server-0.8.3.ebuild')
-rw-r--r--net-misc/guacamole-server/guacamole-server-0.8.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/guacamole-server/guacamole-server-0.8.3.ebuild b/net-misc/guacamole-server/guacamole-server-0.8.3.ebuild
new file mode 100644
index 000000000000..e7dc62387b17
--- /dev/null
+++ b/net-misc/guacamole-server/guacamole-server-0.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+DESCRIPTION="This is the proxy-daemon used by www-apps/guacamole"
+
+HOMEPAGE="http://guacamole.sourceforge.net/"
+SRC_URI="mirror://sourceforge/guacamole/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="rdesktop vnc ssh pulseaudio vorbis"
+
+DEPEND="x11-libs/cairo
+ ssh? ( x11-libs/pango
+ net-libs/libssh )
+ rdesktop? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ vnc? ( net-libs/libvncserver
+ pulseaudio? ( media-sound/pulseaudio ) )
+ vorbis? ( media-libs/libvorbis )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-init-dir=/etc/init.d
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}