summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/gwhois/gwhois-20120626.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/gwhois/gwhois-20120626.ebuild')
-rw-r--r--net-misc/gwhois/gwhois-20120626.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/gwhois/gwhois-20120626.ebuild b/net-misc/gwhois/gwhois-20120626.ebuild
new file mode 100644
index 000000000000..d5674a8bb60d
--- /dev/null
+++ b/net-misc/gwhois/gwhois-20120626.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P/_p/.}
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="generic whois"
+HOMEPAGE="http://gwhois.de/"
+SRC_URI="http://gwhois.de/gwhois/${MY_P/-/_}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="www-client/lynx
+ net-misc/curl
+ dev-lang/perl
+ dev-perl/libwww-perl
+ dev-perl/Net-LibIDN"
+
+src_install() {
+ dodir /etc/gwhois
+ insinto /etc/gwhois
+ doins pattern
+ dobin gwhois
+ doman gwhois.1
+ dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE
+ einfo ""
+ einfo "See included gwhois.xinetd for an example on how to"
+ einfo "use gwhois as a whois proxy using xinetd."
+ einfo "Just copy gwhois.xinetd to /etc/xinetd.d/gwhois"
+ einfo "and reload xinetd."
+ einfo ""
+}
+
+pkg_postinst() {
+ if [ -f /etc/gwhois/pattern.ripe ]; then
+ ewarn ""
+ ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+ ewarn "as it causes malfunction with this version."
+ ewarn "If you did not modify the file, just remove it."
+ ewarn ""
+ mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+ fi
+}