summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-01 18:26:55 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-02-01 18:26:55 -0500
commit3332a8491230fcb2f2507c6c89638429aa89908a (patch)
tree61916c8968657d1d1e9e6bea81514018d3c861a8 /net-misc/haeredes/haeredes-0.5.1.ebuild
parentapp-emulation/ski: tweak for binutils-2.34 (diff)
downloadgentoo-3332a8491230fcb2f2507c6c89638429aa89908a.tar.gz
gentoo-3332a8491230fcb2f2507c6c89638429aa89908a.tar.bz2
gentoo-3332a8491230fcb2f2507c6c89638429aa89908a.zip
net-misc/haeredes: new version 0.5.2.
This new version removes all of the hard-coded compiler options from the build system. Even though that's how it's generally done in the Haskell world, it makes things crashy when some flags are not available in some versions of the compiler. The HCFLAGS variable in Gentoo will still be passed through. Closes: https://bugs.gentoo.org/707806 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-misc/haeredes/haeredes-0.5.1.ebuild')
-rw-r--r--net-misc/haeredes/haeredes-0.5.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/net-misc/haeredes/haeredes-0.5.1.ebuild b/net-misc/haeredes/haeredes-0.5.1.ebuild
deleted file mode 100644
index 7b8eb5a35cbd..000000000000
--- a/net-misc/haeredes/haeredes-0.5.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CABAL_FEATURES="bin test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Confirm delegation of NS and MX records"
-HOMEPAGE="http://michael.orlitzky.com/code/haeredes.xhtml"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# The test suite requires network access.
-RESTRICT="test"
-
-RDEPEND=">=dev-haskell/cmdargs-0.10:=
- >=dev-haskell/dns-1.4:=
- >=dev-haskell/iproute-1.2:=
- >=dev-haskell/parallel-io-0.3:=
- >=dev-lang/ghc-7.6.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.16.0
- test? ( >=dev-haskell/doctest-0.9
- >=dev-haskell/filemanip-0.3.6
- dev-util/shelltestrunner )
-"
-
-src_install() {
- haskell-cabal_src_install
- doman "${S}/doc/man1/${PN}.1"
-}