summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMickaël Schoentgen <contact@tiger-222.fr>2021-10-14 15:06:29 +0200
committerSam James <sam@gentoo.org>2021-10-20 01:50:17 +0000
commita9439d542d5549c294cecd67250d4b27a260eff1 (patch)
tree4e9ac49e4e550483d742d5ee78e852fd36d02a2e /net-misc/httpie
parentsys-fs/loop-aes: drop old (diff)
downloadgentoo-a9439d542d5549c294cecd67250d4b27a260eff1.tar.gz
gentoo-a9439d542d5549c294cecd67250d4b27a260eff1.tar.bz2
gentoo-a9439d542d5549c294cecd67250d4b27a260eff1.zip
net-misc/httpie: version bump to 2.6.0
Signed-off-by: Mickaël Schoentgen <contact@tiger-222.fr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/httpie')
-rw-r--r--net-misc/httpie/Manifest1
-rw-r--r--net-misc/httpie/httpie-2.6.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/httpie/Manifest b/net-misc/httpie/Manifest
index 3779e5c114ab..e11717c65345 100644
--- a/net-misc/httpie/Manifest
+++ b/net-misc/httpie/Manifest
@@ -1,2 +1,3 @@
DIST httpie-2.4.0.tar.gz 1772537 BLAKE2B 111451cc7dc353d5b586554f98ac715a3198f03e74d261944a5f021d2dcc948455500800222b323d182a2a067d0549bda7c318ab3a6c934b9a9beec64aff2db2 SHA512 44cc7ff4fe0f3d8c53a7dd750465f6b56c36f5bbac06d22b760579bd60949039e82313845699669a659ec91adc69dbeac22c06ddd63af64e6f2e0edecf3e732a
DIST httpie-2.5.0.tar.gz 1105177 BLAKE2B 6e16868c81522d4e6d2fc0a4e093c190f18ced720b35217930865ae3f8e168193cc33dfecc13c5d310f52647d6e79d17b247f56e56e8586d633a2d9502be66a7 SHA512 f14aa23fea7578181b9bd6ededea04de9ddf0b2f697b23f76d2d96e2c17b95617318c711750bad6af550400dbc03732ab17fdf84e59d577f33f073e600a55330
+DIST httpie-2.6.0.tar.gz 1133495 BLAKE2B 3ac61fc68ab59ac7523b030a8c7af85c4af05357aa19282b514b813351efabe783f47ab82d292117e0a9170ff793b71356941dc4eb159c585629cae3adec9b5a SHA512 acd7dc847b67e27909c49ccddec84321c4d73fa5b49f06ce3d94d790093a8f168a1c6627bc4921ca8c0e48b9904f38e17935b645495e2313d16ac2eecf659038
diff --git a/net-misc/httpie/httpie-2.6.0.ebuild b/net-misc/httpie/httpie-2.6.0.ebuild
new file mode 100644
index 000000000000..a663fcd882b5
--- /dev/null
+++ b/net-misc/httpie/httpie-2.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.io/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/httpie/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/charset_normalizer[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}