summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-20 01:18:46 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-20 01:18:46 +0200
commit213ecf6cd6f7d590c37fea936a910cc2d21625bc (patch)
tree518ed23ae6d527eb0711a71c2124840c42704285 /net-misc/ifenslave
parentnet-irc/weechat: drop old (diff)
downloadgentoo-213ecf6cd6f7d590c37fea936a910cc2d21625bc.tar.gz
gentoo-213ecf6cd6f7d590c37fea936a910cc2d21625bc.tar.bz2
gentoo-213ecf6cd6f7d590c37fea936a910cc2d21625bc.zip
net-misc/ifenslave: Port to EAPI 7
Closes: https://bugs.gentoo.org/742131 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/ifenslave')
-rw-r--r--net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild b/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild
index 8199a0f5a180..a5a85b6fa342 100644
--- a/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild
+++ b/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
MY_PN="ifenslave-2.6" # this is NOT an error
DEBIAN_PV="17"
@@ -12,36 +12,36 @@ DEBIANPKG_BASE="mirror://debian/pool/main/${MY_PN:0:1}/${MY_PN}"
inherit toolchain-funcs linux-info
DESCRIPTION="Attach and detach slave interfaces to a bonding device"
-HOMEPAGE="http://sf.net/projects/bonding/"
-SRC_URI="${DEBIANPKG_BASE}/${DEBIANPKG_TARBALL}
+HOMEPAGE="https://sf.net/projects/bonding/"
+SRC_URI="
+ ${DEBIANPKG_BASE}/${DEBIANPKG_TARBALL}
${DEBIANPKG_BASE}/${DEBIANPKG_PATCH}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~mips ppc sparc x86"
-IUSE=""
-RDEPEND=""
-DEPEND="sys-devel/gcc
- >=sys-kernel/linux-headers-2.4.22
- ${RDEPEND}"
+DEPEND=">=sys-kernel/linux-headers-2.4.22"
CONFIG_CHECK="~BONDING"
WARNING_BONDING="CONFIG_BONDING is required to get bond devices in the kernel"
+src_configure() {
+ tc-export CC
+}
+
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -o ${PN} || die "Failed to compile!"
+ emake ifenslave
}
src_install() {
into /
- dosbin ${PN}
- into
+ dosbin ifenslave
# there really is no better documentation than the sourcecode :-)
- dodoc ${PN}.c
+ dodoc ifenslave.c
- doman "${WORKDIR}/debian/${PN}.8"
+ doman "${WORKDIR}"/debian/ifenslave.8
}
pkg_preinst() {