summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-28 16:40:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-28 16:46:00 +0200
commitc80f7a43e5789f3be0e39bbae4c29b6e25ab5e61 (patch)
treeaf486aa28bc8b20f73fd123bf31aeed229251409 /net-misc/iputils/iputils-99999999.ebuild
parentdev-util/ninja: Stable on amd64 (diff)
downloadgentoo-c80f7a43e5789f3be0e39bbae4c29b6e25ab5e61.tar.gz
gentoo-c80f7a43e5789f3be0e39bbae4c29b6e25ab5e61.tar.bz2
gentoo-c80f7a43e5789f3be0e39bbae4c29b6e25ab5e61.zip
net-misc/iputils: Update live ebuild
Closes: https://github.com/gentoo/gentoo/pull/5591 Closes: https://bugs.gentoo.org/628240 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'net-misc/iputils/iputils-99999999.ebuild')
-rw-r--r--net-misc/iputils/iputils-99999999.ebuild51
1 files changed, 31 insertions, 20 deletions
diff --git a/net-misc/iputils/iputils-99999999.ebuild b/net-misc/iputils/iputils-99999999.ebuild
index ce003cbf4fee..9731575e02e3 100644
--- a/net-misc/iputils/iputils-99999999.ebuild
+++ b/net-misc/iputils/iputils-99999999.ebuild
@@ -3,20 +3,22 @@
# For released versions, we precompile the man/html pages and store
# them in a tarball on our mirrors. This avoids ugly issues while
-# building stages, and when the jade/sgml packages are broken (which
-# seems to be more common than would be nice).
-# Required packages for doc generation:
-# app-text/docbook-sgml-utils
+# building stages, and reduces depedencies.
+# To regenerate man/html pages emerge iputils-99999999[doc] with
+# EGIT_COMMIT set to release tag and tar ${S}/doc folder.
-EAPI=5
+EAPI="6"
+
+inherit flag-o-matic toolchain-funcs fcaps
+
+PATCHES=( "${FILESDIR}"/${PN}-99999999-tracepath46.patch )
-inherit flag-o-matic eutils toolchain-funcs fcaps
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="https://github.com/iputils/iputils.git"
inherit git-r3
else
SRC_URI="https://github.com/iputils/iputils/archive/s${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~polynomial-c/iputils-s${PV}-manpages.tar.xz"
+ https://dev.gentoo.org/~whissi/dist/iputils/${PN}-manpages-${PV}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux"
fi
@@ -43,13 +45,13 @@ RDEPEND="arping? ( !net-misc/arping )
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )
- virtual/os-headers"
+ virtual/os-headers
+"
if [[ ${PV} == "99999999" ]] ; then
- DEPEND+="
- app-text/openjade
- dev-perl/SGMLSpm
- app-text/docbook-sgml-dtd
- app-text/docbook-sgml-utils
+ DEPEND+="app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt:0
"
fi
@@ -58,7 +60,9 @@ REQUIRED_USE="ipv6? ( ssl? ( ^^ ( gcrypt nettle openssl ) ) )"
[ "${PV}" = "99999999" ] || S="${WORKDIR}/${PN}-s${PV}"
src_prepare() {
- use SECURITY_HAZARD && epatch "${FILESDIR}"/${PN}-20150815-nonroot-floodping.patch
+ use SECURITY_HAZARD && PATCHES+=( "${FILESDIR}"/${PN}-20150815-nonroot-floodping.patch )
+
+ default
}
src_configure() {
@@ -70,7 +74,6 @@ src_configure() {
)
if use ipv6 ; then
TARGETS+=(
- $(usex tracepath 'tracepath6' '')
$(usex traceroute 'traceroute6' '')
)
fi
@@ -100,7 +103,9 @@ src_compile() {
${myconf[@]}
if [[ ${PV} == "99999999" ]] ; then
- emake html man
+ emake man
+
+ use doc && emake html
fi
}
@@ -121,8 +126,14 @@ src_install() {
into /usr
+ if use tracepath ; then
+ dosbin tracepath
+ doman doc/tracepath.8
+ dosym tracepath /usr/sbin/tracepath4
+ fi
+
local u
- for u in clockdiff rarpd rdisc tftpd tracepath ; do
+ for u in clockdiff rarpd rdisc tftpd ; do
if use ${u} ; then
case ${u} in
clockdiff) dobin ${u};;
@@ -133,7 +144,7 @@ src_install() {
done
if use tracepath && use ipv6 ; then
- dosbin tracepath6
+ dosym tracepath /usr/sbin/tracepath6
dosym tracepath.8 /usr/share/man/man8/tracepath6.8
fi
@@ -147,9 +158,9 @@ src_install() {
newconfd "${FILESDIR}"/rarpd.conf.d rarpd
fi
- dodoc INSTALL.md RELNOTES
+ dodoc INSTALL.md
- use doc && dohtml doc/*.html
+ use doc && dodoc doc/*.html
}
pkg_postinst() {