summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-09-24 12:14:43 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-09-24 12:14:53 -0400
commitd10d35d0ec2905cdf5079b4275639158246d90e7 (patch)
tree85866af0a37bfa5d5229dde2144aa038359094fb /net-misc/ipv6calc/ipv6calc-1.0.0.ebuild
parentsys-libs/binutils-libs: Stabilize 2.37_p1 arm64, #813762 (diff)
downloadgentoo-d10d35d0ec2905cdf5079b4275639158246d90e7.tar.gz
gentoo-d10d35d0ec2905cdf5079b4275639158246d90e7.tar.bz2
gentoo-d10d35d0ec2905cdf5079b4275639158246d90e7.zip
net-misc/ipv6calc: version bump to 3.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-1.0.0.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-1.0.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-1.0.0.ebuild b/net-misc/ipv6calc/ipv6calc-1.0.0.ebuild
deleted file mode 100644
index 86d615e8a1ea..000000000000
--- a/net-misc/ipv6calc/ipv6calc-1.0.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-DESCRIPTION="IPv6 address calculator"
-HOMEPAGE="https://www.deepspace6.net/projects/ipv6calc.html"
-SRC_URI="https://github.com/pbiering/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ppc sparc x86 ~amd64-linux ~x86-linux"
-IUSE="geoip test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/openssl:=
- geoip? ( >=dev-libs/geoip-1.4.7 )
-"
-DEPEND="${RDEPEND}
- test? ( dev-perl/Digest-SHA1 )
-"
-
-#dev-perl/URI is needed for web interface, that is not installed now
-
-src_configure() {
- # These options are broken. You can't disable them. That's
- # okay because we want then force enabled.
- # --disable-db-as-registry
- # --disable-db-cc-registry
- if use geoip; then
- myconf=$(use_enable geoip)
- myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
- fi
- econf \
- --disable-bundled-getopt \
- --disable-bundled-md5 \
- --enable-shared \
- --enable-dynamic-load \
- --enable-db-ieee \
- --enable-db-ipv4 \
- --enable-db-ipv6 \
- --disable-dbip \
- --disable-external \
- --disable-ip2location \
- ${myconf}
-}
-
-src_compile() {
- # Disable default CFLAGS (-O2 and -g)
- emake DEFAULT_CFLAGS=""
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]]; then
- # Disable tests that fail as root
- echo true > ipv6logstats/test_ipv6logstats.sh
- fi
- default
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ChangeLog CREDITS README TODO USAGE
-}