summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-27 21:21:28 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-27 21:21:43 -0400
commit71d4cda845579378ff1aedfefca8a9b7ecc0b35f (patch)
tree69850224c643efd04b23c62e49da78e5a8161f54 /net-misc/ipv6calc/ipv6calc-2.1.0.ebuild
parentnet-misc/stunnel: drop older unstable versions (diff)
downloadgentoo-71d4cda845579378ff1aedfefca8a9b7ecc0b35f.tar.gz
gentoo-71d4cda845579378ff1aedfefca8a9b7ecc0b35f.tar.bz2
gentoo-71d4cda845579378ff1aedfefca8a9b7ecc0b35f.zip
net-misc/ipv6calc: version bump to 2.1.0
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-2.1.0.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-2.1.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-2.1.0.ebuild b/net-misc/ipv6calc/ipv6calc-2.1.0.ebuild
new file mode 100644
index 000000000000..12762462078f
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-2.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="https://github.com/pbiering/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="geoip libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Digest-SHA1 )
+"
+
+#dev-perl/URI is needed for web interface, that is not installed now
+
+src_configure() {
+ # These options are broken. You can't disable them. That's
+ # okay because we want then force enabled.
+ # --disable-db-as-registry
+ # --disable-db-cc-registry
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ fi
+ econf \
+ --disable-bundled-getopt \
+ --disable-bundled-md5 \
+ --enable-shared \
+ --enable-dynamic-load \
+ --enable-db-ieee \
+ --enable-db-ipv4 \
+ --enable-db-ipv6 \
+ --disable-dbip \
+ --disable-dbip2 \
+ --disable-external \
+ --disable-ip2location \
+ --disable-mod_ipv6calc \
+ ${myconf}
+}
+
+src_compile() {
+ emake distclean
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}