summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-11 21:05:17 +0100
committerBen Kohler <bkohler@gentoo.org>2021-02-12 07:44:38 -0600
commit64f296e242dae176d0e5cf512d05d919f82ea90f (patch)
tree0ca5eeb61ba09ab991e683122fcf5e79f9013eed /net-misc/liveice/liveice-2000530-r2.ebuild
parentapp-text/cuneiform: Port to EAPI 7 (diff)
downloadgentoo-64f296e242dae176d0e5cf512d05d919f82ea90f.tar.gz
gentoo-64f296e242dae176d0e5cf512d05d919f82ea90f.tar.bz2
gentoo-64f296e242dae176d0e5cf512d05d919f82ea90f.zip
net-misc/liveice: Apply gcc-10 workaround
* Dead upstream Closes: https://bugs.gentoo.org/708642 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/liveice/liveice-2000530-r2.ebuild')
-rw-r--r--net-misc/liveice/liveice-2000530-r2.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/net-misc/liveice/liveice-2000530-r2.ebuild b/net-misc/liveice/liveice-2000530-r2.ebuild
index 9b714278e0a2..cc73e827d6ac 100644
--- a/net-misc/liveice/liveice-2000530-r2.ebuild
+++ b/net-misc/liveice/liveice-2000530-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Live Source Client For IceCast"
HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
@@ -13,15 +13,13 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 x86"
-RDEPEND="media-sound/lame
+RDEPEND="
+ media-sound/lame
media-sound/mpg123"
-DEPEND=""
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
src_prepare() {
default
@@ -29,7 +27,12 @@ src_prepare() {
tc-export CC
}
+src_configure() {
+ append-flags -fcommon
+ default
+}
+
src_install() {
dobin liveice
- dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt
+ dodoc liveice.cfg README.{liveice,quickstart} README_new_mixer.txt Changes.txt
}