summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-15 00:45:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-15 00:45:40 +0200
commit05db8de30dcd44299c3f5b4ee181a7bc4b839690 (patch)
tree810810bbde6dbd86487f31f9944effff3758fb6c /net-misc/lksctp-tools/lksctp-tools-1.0.19.ebuild
parentdev-python/flask: Remove old (diff)
downloadgentoo-05db8de30dcd44299c3f5b4ee181a7bc4b839690.tar.gz
gentoo-05db8de30dcd44299c3f5b4ee181a7bc4b839690.tar.bz2
gentoo-05db8de30dcd44299c3f5b4ee181a7bc4b839690.zip
net-misc/lksctp-tools: bump to v1.0.19
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/lksctp-tools/lksctp-tools-1.0.19.ebuild')
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.19.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.19.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.19.ebuild
new file mode 100644
index 000000000000..6ff9fd80eaae
--- /dev/null
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.19.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic autotools linux-info multilib-minimal
+
+DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
+HOMEPAGE="http://lksctp.sourceforge.net/"
+SRC_URI="https://github.com/sctp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="kernel_linux static-libs"
+
+# This is only supposed to work with Linux to begin with.
+DEPEND=">=sys-kernel/linux-headers-2.6"
+RDEPEND=""
+
+REQUIRED_USE="kernel_linux"
+
+CONFIG_CHECK="~IP_SCTP"
+WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README ROADMAP )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+
+ dodoc doc/*txt
+ newdoc src/withsctp/README README.withsctp
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}