summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-11 12:00:09 +0000
committerSam James <sam@gentoo.org>2021-03-11 12:00:50 +0000
commit10c30113ffd7419f21c8fc99ac5aeee80951b05f (patch)
treeebaac552c5557d791c63e4278aae36dd7bd793e2 /net-misc/lksctp-tools
parentx11-themes/e-flat-theme: add <stabilize-allarches/> (diff)
downloadgentoo-10c30113ffd7419f21c8fc99ac5aeee80951b05f.tar.gz
gentoo-10c30113ffd7419f21c8fc99ac5aeee80951b05f.tar.bz2
gentoo-10c30113ffd7419f21c8fc99ac5aeee80951b05f.zip
net-misc/lksctp-tools: add upstream autoconf-2.70 patch
Thanks-to: Sergei Trofimovich <slyfox@gentoo.org> Closes: https://bugs.gentoo.org/775419 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/lksctp-tools')
-rw-r--r--net-misc/lksctp-tools/files/lksctp-tools-1.0.18-autoconf-2.70.patch82
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild7
2 files changed, 87 insertions, 2 deletions
diff --git a/net-misc/lksctp-tools/files/lksctp-tools-1.0.18-autoconf-2.70.patch b/net-misc/lksctp-tools/files/lksctp-tools-1.0.18-autoconf-2.70.patch
new file mode 100644
index 000000000000..fa7b4195d93b
--- /dev/null
+++ b/net-misc/lksctp-tools/files/lksctp-tools-1.0.18-autoconf-2.70.patch
@@ -0,0 +1,82 @@
+From d6d7130f0a2e3b81880fca29966e42c1b2be40a7 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Fri, 8 Jan 2021 22:22:52 +0000
+Subject: [PATCH] m4/sctp.m4: make conpatible to autoconf-2.70
+
+On recently released `autoconf-2.70` generated `./configure`
+fails as:
+
+```
+$ ./configure
+...
+checking for struct sctp_event_subscribe.sctp_stream_reset_event... yes
+checking for gcc options needed to detect all undeclared functions... none needed
+./configure: line 16464: syntax error: unexpected end of file
+```
+
+This happens becuase new autoconf generates less whitespace:
+
+```
+{
+if ...
+...
+fi}
+```
+
+It requires at least whitespace between `fi` and `}`.
+
+As input already has newlines the change just drops extra `{}`.
+
+Tested on `autoconf-2.69` and `autoconf-2.70`.
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Signed-off-by: Marcelo Ricardo Leitner <marcelo.leitner@gmail.com>
+---
+ m4/sctp.m4 | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/m4/sctp.m4 b/m4/sctp.m4
+index 6593517..94527a6 100644
+--- a/m4/sctp.m4
++++ b/m4/sctp.m4
+@@ -6,7 +6,7 @@
+
+ # Macros to assist on probing kernel features
+ # Probes if a type is defined
+-AC_DEFUN([LKSCTP_CHECK_TYPE], [{
++AC_DEFUN([LKSCTP_CHECK_TYPE], [
+ AC_CHECK_TYPE([$1],
+ AC_DEFINE([$2], 1,
+ [Define if $1 is present.])
+@@ -22,10 +22,10 @@ AC_CHECK_TYPE([$1],
+ #ifdef HAVE_LINUX_SCTP_H
+ # include <linux/sctp.h>
+ #endif
+-])}])
++])])
+
+ # Probes if a struct has a given member
+-AC_DEFUN([LKSCTP_CHECK_MEMBER], [{
++AC_DEFUN([LKSCTP_CHECK_MEMBER], [
+ AC_CHECK_MEMBER([$1],
+ AC_DEFINE([$2], 1,
+ [Define if $1 is present.])
+@@ -41,10 +41,10 @@ AC_CHECK_MEMBER([$1],
+ #ifdef HAVE_LINUX_SCTP_H
+ # include <linux/sctp.h>
+ #endif
+-])}])
++])])
+
+ # Probes if a declaration is present
+-AC_DEFUN([LKSCTP_CHECK_DECL], [{
++AC_DEFUN([LKSCTP_CHECK_DECL], [
+ AC_CHECK_DECL([$1],
+ AC_DEFINE([$2], 1,
+ [Define if $1 is present.])
+@@ -60,4 +60,4 @@ AC_CHECK_DECL([$1],
+ #ifdef HAVE_LINUX_SCTP_H
+ # include <linux/sctp.h>
+ #endif
+-])}])
++])])
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild
index 3f696ca7327d..bf3050d07acf 100644
--- a/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -25,7 +25,10 @@ WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
DOCS=( AUTHORS ChangeLog INSTALL NEWS README ROADMAP )
-PATCHES=( "${FILESDIR}"/${P}-install-sctp.h.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-install-sctp.h.patch
+ "${FILESDIR}"/${P}-autoconf-2.70.patch
+)
src_prepare() {
default