summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/miniupnpd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/miniupnpd/files')
-rw-r--r--net-misc/miniupnpd/files/miniupnpd-1.10-build.patch83
-rw-r--r--net-misc/miniupnpd/files/miniupnpd-conf.d2
-rw-r--r--net-misc/miniupnpd/files/miniupnpd-init.d23
3 files changed, 108 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/files/miniupnpd-1.10-build.patch b/net-misc/miniupnpd/files/miniupnpd-1.10-build.patch
new file mode 100644
index 000000000000..cd2350766c5d
--- /dev/null
+++ b/net-misc/miniupnpd/files/miniupnpd-1.10-build.patch
@@ -0,0 +1,83 @@
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -75,70 +75,10 @@ LDFLAGS += $(shell $(PKG_CONFIG) --libs-
+ LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-other libiptc)
+ else
+
+-ifeq "$(wildcard /etc/gentoo-release )" ""
+-LDLIBS ?= -liptc
+-else # gentoo
+-# the following is better, at least on gentoo with iptables 1.4.6
+-# see http://miniupnp.tuxfamily.org/forum/viewtopic.php?p=1618
+-# and http://miniupnp.tuxfamily.org/forum/viewtopic.php?p=2183
+-LDLIBS ?= -lip4tc
+-CPPFLAGS := -DIPTABLES_143 $(CPPFLAGS)
+-endif
+-
+-ARCH ?= $(shell uname -m | grep -q "x86_64" && echo 64)
+-ifdef IPTABLESPATH
+-CPPFLAGS := $(CPPFLAGS) -I$(IPTABLESPATH)/include/
+-LDFLAGS := $(LDFLAFGS) -L$(IPTABLESPATH)/libiptc/
+-# get iptables version and set IPTABLES_143 macro if needed
+-ifeq ($(TARGET_OPENWRT),)
+-IPTABLESVERSION := $(shell grep "\#define VERSION" $(IPTABLESPATH)/config.h | tr -d \" |cut -d" " -f3 )
+-IPTABLESVERSION1 := $(shell echo $(IPTABLESVERSION) | cut -d. -f1 )
+-IPTABLESVERSION2 := $(shell echo $(IPTABLESVERSION) | cut -d. -f2 )
+-IPTABLESVERSION3 := $(shell echo $(IPTABLESVERSION) | cut -d. -f3 )
+-# test if iptables version >= 1.4.3
+-TEST := $(shell [ \( \( $(IPTABLESVERSION1) -ge 1 \) -a \( $(IPTABLESVERSION2) -ge 4 \) \) -a \( $(IPTABLESVERSION3) -ge 3 \) ] && echo 1 )
+-ifeq ($(TEST), 1)
+-CPPFLAGS := $(CPPFLAGS) -DIPTABLES_143
+-# the following sucks, but works
+-LDLIBS = $(IPTABLESPATH)/libiptc/.libs/libip4tc.o
+-#LDLIBS = $(IPTABLESPATH)/libiptc/.libs/libiptc.a
+-else # ifeq ($(TEST), 1)
+-LDLIBS = $(IPTABLESPATH)/libiptc/libiptc.a
+-endif # ifeq ($(TEST), 1)
+-else # ($(TARGET_OPENWRT),)
+-# openWRT :
+-# check for system-wide iptables files. Test if iptables version >= 1.4.3
+-# the following test has to be verified :
+-TEST := $(shell test -f /usr/include/iptables/internal.h && grep -q "\#define IPTABLES_VERSION" /usr/include/iptables/internal.h && echo 1)
+-ifeq ($(TEST), 1)
+-CPPFLAGS := $(CPPFLAGS) -DIPTABLES_143
+-LDLIBS = -liptc
+-endif # ($(TEST), 1)
+-TEST_LIB := $(shell test -f /usr/lib$(ARCH)/libiptc.a && echo 1)
+-ifeq ($(TEST_LIB), 1)
+-LDLIBS = -liptc /usr/lib$(ARCH)/libiptc.a
+-endif # ($(TEST_LIB), 1)
+-endif # ($(TARGET_OPENWRT),)
+-else # ifdef IPTABLESPATH
+-# IPTABLESPATH not defined
+-# the following test has to be verified :
+-TEST := $(shell test -f /usr/include/xtables.h && grep -q "XTABLES_VERSION_CODE" /usr/include/xtables.h && echo 1)
+-ifeq ($(TEST), 1)
+-CPPFLAGS := $(CPPFLAGS) -DIPTABLES_143
+-LDLIBS = -liptc
+-TESTIP4TC := $(shell test -f /lib/libip4tc.so && echo 1)
+-ifeq ($(TESTIP4TC), 1)
+-LDLIBS := $(LDLIBS) -lip4tc
+-endif # ($(TESTIP4TC), 1)
+-TESTIP6TC := $(shell test -f /lib/libip6tc.so && echo 1)
+-ifeq ($(TESTIP6TC), 1)
+-LDLIBS := $(LDLIBS) -lip6tc
+-endif # ($(TESTIP6TC), 1)
+-endif # ($(TEST), 1)
+-endif # ifdef IPTABLESPATH
+ endif # ifdef PCFILE_FOUND
+
+-LDLIBS += -lnfnetlink
++LDLIBS += -lip4tc -lnfnetlink
++CPPFLAGS += -DIPTABLES_143
+
+ TEST := $(shell $(PKG_CONFIG) --atleast-version=1.0.2 libnetfilter_conntrack && $(PKG_CONFIG) --atleast-version=1.0.3 libmnl && echo 1)
+ ifeq ($(TEST),1)
+@@ -184,7 +124,6 @@ install: miniupnpd miniupnpd.8 miniupnpd
+ $(INSTALL) linux/miniupnpd.init.d.script $(DESTDIR)$(PREFIX)/etc/init.d/miniupnpd
+ $(INSTALL) -d $(DESTDIR)$(MANINSTALLDIR)
+ $(INSTALL) --mode=0644 miniupnpd.8 $(DESTDIR)$(MANINSTALLDIR)
+- gzip -f $(DESTDIR)$(MANINSTALLDIR)/miniupnpd.8
+
+ # genuuid is using the uuidgen CLI tool which is part of libuuid
+ # from the e2fsprogs
diff --git a/net-misc/miniupnpd/files/miniupnpd-conf.d b/net-misc/miniupnpd/files/miniupnpd-conf.d
new file mode 100644
index 000000000000..8482ef2d185b
--- /dev/null
+++ b/net-misc/miniupnpd/files/miniupnpd-conf.d
@@ -0,0 +1,2 @@
+ARGS='-f /etc/miniupnpd/miniupnpd.conf'
+
diff --git a/net-misc/miniupnpd/files/miniupnpd-init.d b/net-misc/miniupnpd/files/miniupnpd-init.d
new file mode 100644
index 000000000000..37ccde1f8adb
--- /dev/null
+++ b/net-misc/miniupnpd/files/miniupnpd-init.d
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net iptables
+ use minissdpd
+}
+
+start() {
+ ebegin "Starting miniupnpd"
+ /etc/miniupnpd/iptables_init.sh
+ start-stop-daemon --start --pidfile /var/run/miniupnpd.pid --exec /usr/sbin/miniupnpd -- ${ARGS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping miniupnpd"
+ start-stop-daemon --stop --pidfile /var/run/miniupnpd.pid
+ eend $?
+ /etc/miniupnpd/iptables_removeall.sh
+}