summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-27 18:12:05 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-27 18:17:06 -0400
commitb07b8c315459ba06721a85aa8e7d3f0e26941f92 (patch)
treee2da2096efe8bc5d71fdb7c5b23130945241dc45 /net-misc/modemmanager
parentgui-libs/libhandy: Version bump to 1.2.2 (diff)
downloadgentoo-b07b8c315459ba06721a85aa8e7d3f0e26941f92.tar.gz
gentoo-b07b8c315459ba06721a85aa8e7d3f0e26941f92.tar.bz2
gentoo-b07b8c315459ba06721a85aa8e7d3f0e26941f92.zip
net-misc/modemmanager: Version bump to 1.16.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-misc/modemmanager')
-rw-r--r--net-misc/modemmanager/Manifest1
-rw-r--r--net-misc/modemmanager/modemmanager-1.16.4.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/net-misc/modemmanager/Manifest b/net-misc/modemmanager/Manifest
index 2e5e794ac1f7..160c8b44e158 100644
--- a/net-misc/modemmanager/Manifest
+++ b/net-misc/modemmanager/Manifest
@@ -1,2 +1,3 @@
DIST ModemManager-1.14.8.tar.xz 2255964 BLAKE2B 8f0e4e4747b3603795b533c41949ef7180922e92b7b26348145e18ffaa38f23cccbcb6662ac912216d33b4aef805c5f7ad10aef8029ffd16eb30b331fc2ca88e SHA512 2457214fecd7d4d9fef291f756ef19973b98a05d07721cd57bdaee704cd6b9e96d27f6741bd8d245a0495f1d338e65db12f19b2d9a8dd6a5cddfb050614381c6
DIST ModemManager-1.16.2.tar.xz 2447936 BLAKE2B aafd2bde9fe72ec837a34987a698d82f4ba2aedf778c350263f8fe937ccd4b5b9b78fc66c58a39a8729c371788ab7b7782073726dc132b8f08bd2df0a9bc2da4 SHA512 c0b095972eba6e0f3a1ad22e425b412f17d8b60f0af4d423a92fdebcb6d2801f87e6af98758f8c2dc4db3586a3a15530a318805fda312443fa6abe2265ebd6b6
+DIST ModemManager-1.16.4.tar.xz 2335908 BLAKE2B dfd3293e9b685d3b01fa3deec111aafca6f11dc27be0a69e0496036e537eecb6f51f592ce1996f47c86b5d9db2abf3c9b9a26e66e9f058ba59982caf38b28ef9 SHA512 5fb7625c9d41ce0179b4e59745b00b815038239552a5438d71ff36b019b398fc3dc6bef709e91a186f5f7427fcb59d79c0b1c3ca9c3dca867f0d5677fd979506
diff --git a/net-misc/modemmanager/modemmanager-1.16.4.ebuild b/net-misc/modemmanager/modemmanager-1.16.4.ebuild
new file mode 100644
index 000000000000..5642c599e4ed
--- /dev/null
+++ b/net-misc/modemmanager/modemmanager-1.16.4.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 readme.gentoo-r1 systemd toolchain-funcs udev vala
+
+DESCRIPTION="Modem and mobile broadband management libraries"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/ModemManager/"
+SRC_URI="https://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/1" # subslot = dbus interface version, i.e. N in org.freedesktop.ModemManager${N}
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="elogind +introspection mbim policykit +qmi systemd +udev vala"
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ vala? ( introspection )
+"
+
+DEPEND="
+ >=dev-libs/glib-2.48.0:2
+ udev? ( >=dev-libs/libgudev-230:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+ mbim? ( >=net-libs/libmbim-1.24.0 )
+ policykit? ( >=sys-auth/polkit-0.106[introspection?] )
+ qmi? ( >=net-libs/libqmi-1.28.0:= )
+ elogind? ( sys-auth/elogind )
+ systemd? ( >=sys-apps/systemd-209 )
+"
+RDEPEND="${DEPEND}
+ policykit? ( acct-group/plugdev )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/ModemManager-${PV}"
+
+src_prepare() {
+ DOC_CONTENTS="
+ If your USB modem shows up only as a storage device when you plug it in,
+ then you should install sys-apps/usb_modeswitch, which will automatically
+ switch it over to USB modem mode whenever you plug it in.\n"
+
+ if use policykit; then
+ DOC_CONTENTS+="\nTo control your modem without needing to enter the root password,
+ add your user account to the 'plugdev' group."
+ fi
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=(
+ --disable-Werror
+ --disable-static
+ --with-dist-version=${PVR}
+ --with-udev-base-dir="$(get_udevdir)"
+ $(use_with udev)
+ $(use_enable introspection)
+ $(use_with mbim)
+ $(use_with policykit polkit)
+ $(use_with systemd systemd-journal)
+ $(use_with qmi)
+ $(use_enable vala)
+ )
+ if use systemd || use elogind; then
+ myconf+=(--with-systemd-suspend-resume)
+ else
+ myconf+=(--without-systemd-suspend-resume)
+ fi
+ gnome2_src_configure "${myconf[@]}"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Allow users in plugdev group full control over their modem
+ if use policykit; then
+ insinto /usr/share/polkit-1/rules.d/
+ doins "${FILESDIR}"/01-org.freedesktop.ModemManager1.rules
+ fi
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/modemmanager.initd" modemmanager
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ # The polkit rules file moved to /usr/share
+ old_rules="${EROOT}/etc/polkit-1/rules.d/01-org.freedesktop.ModemManager.rules"
+ if [[ -f "${old_rules}" ]]; then
+ case "$(md5sum ${old_rules})" in
+ c5ff02532cb1da2c7545c3069e5d0992* | 5c50f0dc603c0a56e2851a5ce9389335* )
+ # Automatically delete the old rules.d file if the user did not change it
+ elog
+ elog "Removing old ${old_rules} ..."
+ rm -f "${old_rules}" || eerror "Failed, please remove ${old_rules} manually"
+ ;;
+ * )
+ elog "The ${old_rules}"
+ elog "file moved to /usr/share/polkit-1/rules.d/ in >=modemmanager-0.5.2.0-r2"
+ elog "If you edited ${old_rules}"
+ elog "without changing its behavior, you may want to remove it."
+ ;;
+ esac
+ fi
+
+ if ! use udev; then
+ ewarn "You have built ModemManager without udev support. You may have to teach it"
+ ewarn "about your modem port manually."
+ fi
+
+ systemd_reenable ModemManager.service
+
+ readme.gentoo_print_elog
+}