summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:16:47 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:16:47 -0500
commit68ab45e3f5b741d6e9ef415c8d0f4c83b5af5782 (patch)
tree4fdc5350beeae49a600f5f27b20d750eccdca3fb /net-misc/monmotha
parentnet-misc/midentd: remove old version (diff)
downloadgentoo-68ab45e3f5b741d6e9ef415c8d0f4c83b5af5782.tar.gz
gentoo-68ab45e3f5b741d6e9ef415c8d0f4c83b5af5782.tar.bz2
gentoo-68ab45e3f5b741d6e9ef415c8d0f4c83b5af5782.zip
net-misc/monmotha: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/monmotha')
-rw-r--r--net-misc/monmotha/files/monmotha.rc64
-rw-r--r--net-misc/monmotha/monmotha-2.3.8-r1.ebuild47
2 files changed, 49 insertions, 2 deletions
diff --git a/net-misc/monmotha/files/monmotha.rc6 b/net-misc/monmotha/files/monmotha.rc6
index 50f31b9811cd..30bcca24ab19 100644
--- a/net-misc/monmotha/files/monmotha.rc6
+++ b/net-misc/monmotha/files/monmotha.rc6
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/monmotha/monmotha-2.3.8-r1.ebuild b/net-misc/monmotha/monmotha-2.3.8-r1.ebuild
new file mode 100644
index 000000000000..4f163ff08f92
--- /dev/null
+++ b/net-misc/monmotha/monmotha-2.3.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="MonMotha IPTables-based firewall script"
+HOMEPAGE="http://monmotha.mplug.org/firewall/"
+LICENSE="GPL-2"
+
+KEYWORDS="x86 ~amd64"
+IUSE=""
+SLOT="0"
+RDEPEND=">=net-firewall/iptables-1.2.5"
+
+MY_PVP=(${PV//[-\._]/ })
+
+S=${WORKDIR}
+
+SRC_URI="http://monmotha.mplug.org/~monmotha/firewall/firewall/${MY_PVP[0]}.${MY_PVP[1]}/rc.firewall-${PV}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} "${S}"/
+}
+
+src_install() {
+ newinitd "${FILESDIR}/monmotha.rc6" monmotha
+ exeinto /etc/monmotha
+ newexe "${S}/rc.firewall-${PV}" monmotha
+}
+
+pkg_postinst () {
+ einfo "Don't forget to add the 'monmotha' startup script to your default"
+ einfo "runlevel by typing the following command:"
+ einfo ""
+ einfo " rc-update add monmotha default"
+ einfo ""
+ einfo "You need to edit /etc/monmotha/monmotha before using"
+ einfo "it. Enter the right vars in the file, start the script"
+ einfo "by typing: '/etc/init.d/monmotha start' and it should work."
+ einfo ""
+ einfo "Don't forget to change the path to iptables!!!"
+ einfo ""
+ einfo "Note: If You are stopping the firewall, all iptables rulesets"
+ einfo "will be flushed!!!"
+ einfo ""
+}