summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild')
-rw-r--r--net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild b/net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild
new file mode 100644
index 000000000000..a06307396f48
--- /dev/null
+++ b/net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Netkit - ruptime/rwho/rwhod"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz
+ https://dev.gentoo.org/~jer/${P}-patches.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${WORKDIR}"/000{1,2,3,4}-*.patch
+ epatch "${FILESDIR}"/${P}-printf.patch #529974
+}
+
+src_configure() {
+ # Not an autotools build system
+ ./configure --with-c-compiler=$(tc-getCC) || die
+ sed -i \
+ -e "s:-O2::" \
+ -e "s:-Wpointer-arith::" \
+ MCONFIG || die
+}
+
+src_install() {
+ keepdir /var/spool/rwho
+
+ into /usr
+ dobin ruptime/ruptime rwho/rwho
+ dosbin rwhod/rwhod
+
+ doman ruptime/ruptime.1 rwho/rwho.1 rwhod/rwhod.8
+ dodoc README ChangeLog
+
+ newinitd "${FILESDIR}"/${P}-rc rwhod
+ newconfd "${FILESDIR}"/${P}-confd rwhod
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/${P}-cron
+}