summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netkit-telnetd/netkit-telnetd-0.17-r10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netkit-telnetd/netkit-telnetd-0.17-r10.ebuild')
-rw-r--r--net-misc/netkit-telnetd/netkit-telnetd-0.17-r10.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/netkit-telnetd/netkit-telnetd-0.17-r10.ebuild b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r10.ebuild
new file mode 100644
index 000000000000..a02cf271b464
--- /dev/null
+++ b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r10.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+PATCHLEVEL=36
+DESCRIPTION="Standard Linux telnet client and server"
+#old HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+# This might be the best HOMEPAGE now?
+HOMEPAGE="https://launchpad.net/netkit-telnet"
+# http://packages.debian.org/stablesource/netkit-telnet
+# http://packages.debian.org/testing/source/netkit-telnet
+# No upstream mirror exists anymore?
+# old ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz
+SRC_URI="mirror://gentoo/netkit-telnet-${PV}.tar.gz
+ mirror://debian/pool/main/n/netkit-telnet/netkit-telnet_0.17-${PATCHLEVEL}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2
+ !net-misc/telnet-bsd"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/netkit-telnet-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Patch: [0]
+ # Gentoo lacks a maintainer for this package right now. And a
+ # security problem arose. While reviewing our options for how
+ # should we proceed with the security bug we decided it would be
+ # better to just stay in sync with debian's own netkit-telnet
+ # package. Lots of bug fixes by them over time which were not in
+ # our telnetd.
+ epatch "${WORKDIR}"/netkit-telnet_0.17-${PATCHLEVEL}.diff
+
+ # Patch: [1]
+ # after the deb patch we need to add a small patch that defines
+ # gnu source. This is needed for gcc-3.4.x (needs to be pushed
+ # back to the deb folk?)
+ epatch "${FILESDIR}"/netkit-telnetd-0.17-cflags-gnu_source.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+
+ ./configure --prefix=/usr || die
+
+ sed -i \
+ -e "s:-pipe -O2:${CFLAGS}:" \
+ -e "s:^\(LDFLAGS=\).*:\1${LDFLAGS}:" \
+ -e "s:-Wpointer-arith::" \
+ MCONFIG || die
+
+ emake || die
+ cd telnetlogin && emake || die
+}
+
+src_install() {
+ dobin telnet/telnet || die
+
+ dosbin telnetd/telnetd || die
+ dosym telnetd /usr/sbin/in.telnetd || die
+ dosbin telnetlogin/telnetlogin || die
+ doman telnet/telnet.1 || die
+ doman telnetd/*.8 || die
+ doman telnetd/issue.net.5 || die
+ dosym telnetd.8 /usr/share/man/man8/in.telnetd.8 || die
+ doman telnetlogin/telnetlogin.8 || die
+ dodoc BUGS ChangeLog README || die
+ dodoc "${FILESDIR}"/net.issue.sample || die
+ newdoc telnet/README README.telnet || die
+ newdoc telnet/TODO TODO.telnet || die
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/telnetd.xinetd telnetd || die
+}