summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-24 17:23:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-06 23:47:53 +0200
commit93732127da94577948bdc3bad38d0f344854b4b5 (patch)
treeaeb4af5f94936d7279f2005707d248796e71e0fb /net-misc/netpipe
parentnet-misc/netpipe: use HTTPs (diff)
downloadgentoo-93732127da94577948bdc3bad38d0f344854b4b5.tar.gz
gentoo-93732127da94577948bdc3bad38d0f344854b4b5.tar.bz2
gentoo-93732127da94577948bdc3bad38d0f344854b4b5.zip
net-misc/netpipe: EAPI7, improve ebuild
Diffstat (limited to 'net-misc/netpipe')
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2-r2.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2-r2.ebuild
new file mode 100644
index 000000000000..dbdaac08b108
--- /dev/null
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
+HOMEPAGE="https://www.wudika.de/~jan/netpipe/"
+SRC_URI="https://www.wudika.de/~jan/${PN}/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS} ${LDFLAGS}:" \
+ -e "s:^CC=.*:CC = $(tc-getCC):" \
+ Makefile || die "sed failed"
+ default
+}
+
+src_install() {
+ dobin netpipe
+ dodoc DOCUMENTATION INSTALL TECH-NOTES
+}