summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-07 22:41:44 +0000
committerMikle Kolyada <zlogene@gentoo.org>2020-10-08 22:15:41 +0300
commit1b636741c5d5a793b49abfa914f2d11241fec178 (patch)
treefba82472333c3a5a8fff9ff1400f265ec4ff709f /net-misc/networkmanager
parentdev-lua/luaexpat: update 1.3.0 version branch (diff)
downloadgentoo-1b636741c5d5a793b49abfa914f2d11241fec178.tar.gz
gentoo-1b636741c5d5a793b49abfa914f2d11241fec178.tar.bz2
gentoo-1b636741c5d5a793b49abfa914f2d11241fec178.zip
net-misc/networkmanager: drop USE=consolekit
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-misc/networkmanager')
-rw-r--r--net-misc/networkmanager/metadata.xml2
-rw-r--r--net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild (renamed from net-misc/networkmanager/networkmanager-1.18.4-r3.ebuild)21
-rw-r--r--net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild (renamed from net-misc/networkmanager/networkmanager-1.18.6.ebuild)22
-rw-r--r--net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild (renamed from net-misc/networkmanager/networkmanager-1.20.12.ebuild)22
-rw-r--r--net-misc/networkmanager/networkmanager-1.22.10-r12.ebuild (renamed from net-misc/networkmanager/networkmanager-1.22.10-r11.ebuild)11
-rw-r--r--net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild (renamed from net-misc/networkmanager/networkmanager-1.22.14.ebuild)22
-rw-r--r--net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild (renamed from net-misc/networkmanager/networkmanager-1.24.2.ebuild)22
-rw-r--r--net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild (renamed from net-misc/networkmanager/networkmanager-1.26.0.ebuild)22
-rw-r--r--net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild (renamed from net-misc/networkmanager/networkmanager-1.26.2.ebuild)22
9 files changed, 107 insertions, 59 deletions
diff --git a/net-misc/networkmanager/metadata.xml b/net-misc/networkmanager/metadata.xml
index 91e9ff45256e..808f71c51288 100644
--- a/net-misc/networkmanager/metadata.xml
+++ b/net-misc/networkmanager/metadata.xml
@@ -9,8 +9,6 @@
<flag name="concheck">Enable connectivity checking support</flag>
<flag name="connection-sharing">Use <pkg>net-dns/dnsmasq</pkg> and
<pkg>net-firewall/iptables</pkg> for connection sharing</flag>
- <flag name="consolekit">Use <pkg>sys-auth/consolekit</pkg> for session
- tracking</flag>
<flag name="dhclient">Use dhclient from <pkg>net-misc/dhcp</pkg> for
getting ip</flag>
<flag name="dhcpcd">Use <pkg>net-misc/dhcpcd</pkg> for getting ip</flag>
diff --git a/net-misc/networkmanager/networkmanager-1.18.4-r3.ebuild b/net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild
index 453af4ab92ad..3025d516e406 100644
--- a/net-misc/networkmanager/networkmanager-1.18.4-r3.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0" # add subslot if libnm-util.so.2 or libnm-glib.so.4 bumps soname version
-IUSE="audit bluetooth connection-sharing consolekit +dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing +dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~sparc x86"
@@ -47,7 +47,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -185,10 +184,6 @@ multilib_src_configure() {
--with-ebpf=yes
$(multilib_native_enable concheck)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
$(use_with dhclient)
@@ -215,6 +210,18 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.18.6.ebuild b/net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild
index 070ae215d272..5dc2574c7f38 100644
--- a/net-misc/networkmanager/networkmanager-1.18.6.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0" # add subslot if libnm-util.so.2 or libnm-glib.so.4 bumps soname version
-IUSE="audit bluetooth connection-sharing consolekit +dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing +dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~sparc x86"
@@ -47,7 +47,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -185,10 +184,6 @@ multilib_src_configure() {
--with-ebpf=yes
$(multilib_native_enable concheck)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
$(use_with dhclient)
@@ -215,6 +210,19 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ # There is no off switch, and we do not support upower.
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.20.12.ebuild b/net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild
index 81c6f70ed900..df04d0e8e171 100644
--- a/net-misc/networkmanager/networkmanager-1.20.12.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="audit bluetooth connection-sharing consolekit dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -175,10 +174,6 @@ multilib_src_configure() {
--with-ebpf=yes
$(multilib_native_enable concheck)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -207,6 +202,19 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ # There is no off switch, and we do not support upower.
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.22.10-r11.ebuild b/net-misc/networkmanager/networkmanager-1.22.10-r12.ebuild
index b2cd3babde33..7fb85f509cd4 100644
--- a/net-misc/networkmanager/networkmanager-1.22.10-r11.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.22.10-r12.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/archive/
LICENSE="GPL-2+"
SLOT="0" # add subslot if libnm-util.so.2 or libnm-glib.so.4 bumps soname version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="audit bluetooth +concheck connection-sharing consolekit +dhclient dhcpcd "
+IUSE="audit bluetooth +concheck connection-sharing +dhclient dhcpcd "
IUSE+="debug elogind examples +gnutls gtk-doc introspection iwd json kernel_linux "
IUSE+="libpsl lto modemmanager nss ofono ovs +policykit ppp resolvconf selinux "
IUSE+="syslog systemd teamd test +tools vala wext +wifi"
@@ -24,7 +24,7 @@ REQUIRED_USE="
iwd? ( wifi )
vala? ( introspection )
^^ ( gnutls nss )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
?? ( dhclient dhcpcd )
?? ( syslog systemd )
"
@@ -43,7 +43,6 @@ DEPEND="
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables
)
- consolekit? ( sys-auth/consolekit )
dhclient? ( net-misc/dhcp[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( sys-auth/elogind )
@@ -235,11 +234,7 @@ src_configure() {
$(meson_use lto b_lto)
)
- if use consolekit; then
- emesonargs+=( -D session_tracking_consolekit=true )
- emesonargs+=( -D session_tracking=no )
- emesonargs+=( -D suspend_resume=consolekit )
- elif use systemd; then
+ if use systemd; then
emesonargs+=( -D session_tracking_consolekit=false )
emesonargs+=( -D session_tracking=systemd )
emesonargs+=( -D suspend_resume=systemd )
diff --git a/net-misc/networkmanager/networkmanager-1.22.14.ebuild b/net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild
index c7d5376f75d7..d95b52bcbde7 100644
--- a/net-misc/networkmanager/networkmanager-1.22.14.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="audit bluetooth connection-sharing consolekit dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -177,10 +176,6 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -209,6 +204,19 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ # There is no off switch, and we do not support upower.
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.24.2.ebuild b/net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild
index 91ce0e3aeda7..bedfb4ef0ed4 100644
--- a/net-misc/networkmanager/networkmanager-1.24.2.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="audit bluetooth connection-sharing consolekit dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -177,10 +176,6 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -208,6 +203,19 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ # There is no off switch, and we do not support upower.
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.26.0.ebuild b/net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild
index e3cf77c51fed..4df3b435f25b 100644
--- a/net-misc/networkmanager/networkmanager-1.26.0.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="audit bluetooth connection-sharing consolekit dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~sparc x86"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -177,10 +176,6 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -208,6 +203,19 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ # There is no off switch, and we do not support upower.
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.26.2.ebuild b/net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild
index 91ce0e3aeda7..bedfb4ef0ed4 100644
--- a/net-misc/networkmanager/networkmanager-1.26.2.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="audit bluetooth connection-sharing consolekit dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing dhclient dhcpcd elogind gnutls +introspection iwd json kernel_linux +nss +modemmanager ncurses ofono ovs policykit +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -24,7 +24,7 @@ REQUIRED_USE="
vala? ( introspection )
wext? ( wifi )
|| ( nss gnutls )
- ?? ( consolekit elogind systemd )
+ ?? ( elogind systemd )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
connection-sharing? (
net-dns/dnsmasq[dbus,dhcp]
net-firewall/iptables )
- consolekit? ( >=sys-auth/consolekit-1.0.0 )
dhclient? ( >=net-misc/dhcp-4[client] )
dhcpcd? ( net-misc/dhcpcd )
elogind? ( >=sys-auth/elogind-219 )
@@ -177,10 +176,6 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
- --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no)))
- # ConsoleKit has no build-time dependency, so use it as the default case.
- # There is no off switch, and we do not support upower.
- --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -208,6 +203,19 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
+ # There is no off switch, and we do not support upower.
+ if use systemd; then
+ myconf+=(
+ --with-session-tracking=systemd
+ --with-suspend-resume=systemd
+ )
+ elif use elogind; then
+ myconf+=(
+ --with-session-tracking=elogind
+ --with-suspend-resume=elogind
+ )
+ fi
+
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`