summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-09 03:38:19 +0000
committerSam James <sam@gentoo.org>2020-10-09 03:38:19 +0000
commit90701330ab4b859f2e1d57124bd092a85ba7d8cb (patch)
treea033410c201afe3332ce8f77c6ffa1ebbe32a379 /net-misc/networkmanager
parentdev-db/percona-server: remove -Werror (diff)
downloadgentoo-90701330ab4b859f2e1d57124bd092a85ba7d8cb.tar.gz
gentoo-90701330ab4b859f2e1d57124bd092a85ba7d8cb.tar.bz2
gentoo-90701330ab4b859f2e1d57124bd092a85ba7d8cb.zip
net-misc/networkmanager: drop USE=consolekit again
Two problems with the initial draft PR: 1) elogind does not have multilib, so... 2) we must (ab)use 'consolekit' as a dummy option for the build system in the non-native multilib case. Fixes: 1b636741c5d5a793b49abfa914f2d11241fec178 Closes: https://bugs.gentoo.org/747358 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/networkmanager')
-rw-r--r--net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild18
-rw-r--r--net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild19
-rw-r--r--net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild19
-rw-r--r--net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild19
-rw-r--r--net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild19
-rw-r--r--net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild19
-rw-r--r--net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild19
7 files changed, 42 insertions, 90 deletions
diff --git a/net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild b/net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild
index 3025d516e406..baec49b2cdb5 100644
--- a/net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.18.4-r4.ebuild
@@ -184,6 +184,12 @@ multilib_src_configure() {
--with-ebpf=yes
$(multilib_native_enable concheck)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
$(use_with dhclient)
@@ -210,18 +216,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild b/net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild
index 5dc2574c7f38..2f8cca8565b8 100644
--- a/net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.18.6-r1.ebuild
@@ -184,6 +184,12 @@ multilib_src_configure() {
--with-ebpf=yes
$(multilib_native_enable concheck)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
$(use_with dhclient)
@@ -210,19 +216,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- # There is no off switch, and we do not support upower.
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild b/net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild
index df04d0e8e171..3ec06c3aefc0 100644
--- a/net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.20.12-r1.ebuild
@@ -174,6 +174,12 @@ multilib_src_configure() {
--with-ebpf=yes
$(multilib_native_enable concheck)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -202,19 +208,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- # There is no off switch, and we do not support upower.
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild b/net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild
index d95b52bcbde7..a956d94131ee 100644
--- a/net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.22.14-r1.ebuild
@@ -176,6 +176,12 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -204,19 +210,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- # There is no off switch, and we do not support upower.
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild b/net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild
index bedfb4ef0ed4..3c513d596fc9 100644
--- a/net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.24.2-r1.ebuild
@@ -176,6 +176,12 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -203,19 +209,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- # There is no off switch, and we do not support upower.
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild b/net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild
index 4df3b435f25b..021a54dfe6ac 100644
--- a/net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.26.0-r1.ebuild
@@ -176,6 +176,12 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -203,19 +209,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- # There is no off switch, and we do not support upower.
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`
diff --git a/net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild b/net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild
index bedfb4ef0ed4..3c513d596fc9 100644
--- a/net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.26.2-r1.ebuild
@@ -176,6 +176,12 @@ multilib_src_configure() {
$(multilib_native_enable concheck)
--with-nm-cloud-setup=$(multilib_is_native_abi && echo yes || echo no)
--with-crypto=$(usex nss nss gnutls)
+ # elogind lacks multilib for now, and consolekit doesn't require linking against, so we use it as a fake option
+ # This SHOULD be removable once elogind has that. We abuse the fact that 'consolekit' does nothing at buildtime.
+ # (There is no off switch, and we do not support upower.)
+ # bug #747358
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
--without-dhcpcanon
@@ -203,19 +209,6 @@ multilib_src_configure() {
$(multilib_native_use_enable wifi)
)
- # There is no off switch, and we do not support upower.
- if use systemd; then
- myconf+=(
- --with-session-tracking=systemd
- --with-suspend-resume=systemd
- )
- elif use elogind; then
- myconf+=(
- --with-session-tracking=elogind
- --with-suspend-resume=elogind
- )
- fi
-
# Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
if use ppp; then
local PPPD_VER=`best_version net-dialup/ppp`