summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 10:31:35 +0100
committerSam James <sam@gentoo.org>2021-04-21 19:50:18 +0100
commit6e3cb0fb48db41a73bc6c2981f80315923002138 (patch)
treef16985faacaddc58594ade93e481d43d6d2b5a7f /net-misc/ntpsec
parentapp-i18n/scim-anthy: drop epatch (diff)
downloadgentoo-6e3cb0fb48db41a73bc6c2981f80315923002138.tar.gz
gentoo-6e3cb0fb48db41a73bc6c2981f80315923002138.tar.bz2
gentoo-6e3cb0fb48db41a73bc6c2981f80315923002138.zip
net-misc/ntpsec: drop epatch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec')
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.9.ebuild6
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild8
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild6
3 files changed, 10 insertions, 10 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.1.9.ebuild b/net-misc/ntpsec/ntpsec-1.1.9.ebuild
index 9ac6c89d595d..0cfaff72ab52 100644
--- a/net-misc/ntpsec/ntpsec-1.1.9.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.1.9.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python3_{7,8} )
PYTHON_REQ_USE='threads(+)'
-inherit epatch flag-o-matic python-r1 waf-utils systemd
+inherit flag-o-matic python-r1 waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -66,9 +66,9 @@ WAF_BINARY="${S}/waf"
src_prepare() {
default
# Remove autostripping of binaries
- sed -i -e '/Strip binaries/d' wscript
+ sed -i -e '/Strip binaries/d' wscript || die
if ! use libbsd ; then
- epatch "${FILESDIR}/${PN}-no-bsd.patch"
+ eapply "${FILESDIR}/${PN}-no-bsd.patch"
fi
python_copy_sources
}
diff --git a/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild b/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
index f63dc7958aa6..efc382f1edd9 100644
--- a/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE='threads(+)'
DISTUTILS_USE_SETUPTOOLS=no
-inherit epatch distutils-r1 flag-o-matic waf-utils systemd
+inherit distutils-r1 flag-o-matic waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -68,12 +68,12 @@ WAF_BINARY="${S}/waf"
src_prepare() {
default
# Remove autostripping of binaries
- sed -i -e '/Strip binaries/d' wscript
+ sed -i -e '/Strip binaries/d' wscript || die
if ! use libbsd ; then
- epatch "${FILESDIR}/${PN}-no-bsd.patch"
+ eapply "${FILESDIR}/${PN}-no-bsd.patch"
fi
# remove extra default pool servers
- sed -i '/use-pool/s/^/#/' "${S}"/etc/ntp.d/default.conf
+ sed -i '/use-pool/s/^/#/' "${S}"/etc/ntp.d/default.conf || die
python_copy_sources
}
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index c1244770794d..361635d422b3 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python3_{7,8} )
PYTHON_REQ_USE='threads(+)'
-inherit epatch flag-o-matic python-r1 waf-utils systemd
+inherit flag-o-matic python-r1 waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -61,9 +61,9 @@ WAF_BINARY="${S}/waf"
src_prepare() {
default
# Remove autostripping of binaries
- sed -i -e '/Strip binaries/d' wscript
+ sed -i -e '/Strip binaries/d' wscript || die
if ! use libbsd ; then
- epatch "${FILESDIR}/${PN}-no-bsd.patch"
+ eapply "${FILESDIR}/${PN}-no-bsd.patch"
fi
python_copy_sources
}