summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-10 21:09:31 +0000
committerSam James <sam@gentoo.org>2021-06-10 21:09:31 +0000
commita87107cfff01e74e3519624360dbd72a60a1fdd9 (patch)
tree7d821b048a3f2d38b8a07bfcb63fcbba2e013af3 /net-misc/ntpsec
parentsys-fs/static-dev: fix ROOT check for EAPI 7 (diff)
downloadgentoo-a87107cfff01e74e3519624360dbd72a60a1fdd9.tar.gz
gentoo-a87107cfff01e74e3519624360dbd72a60a1fdd9.tar.bz2
gentoo-a87107cfff01e74e3519624360dbd72a60a1fdd9.zip
net-misc/ntpsec: add seccomp patch from upstream
Closes: https://bugs.gentoo.org/786228 Closes: https://bugs.gentoo.org/705128 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec')
-rw-r--r--net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch19
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild (renamed from net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild)5
2 files changed, 22 insertions, 2 deletions
diff --git a/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch b/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
new file mode 100644
index 000000000000..e4dc47f19cc6
--- /dev/null
+++ b/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/705128
+--- a/ntpd/ntp_sandbox.c
++++ b/ntpd/ntp_sandbox.c
+@@ -463,6 +463,15 @@ int scmp_sc[] = {
+ SCMP_SYS(send),
+ SCMP_SYS(stat64),
+ #endif
++#if defined(__arm__)
++ SCMP_SYS(statx),
++#endif
++#if defined(__riscv32__)
++ SCMP_SYS(faccessat),
++#endif
++#if defined(__aarch64__)
++ SCMP_SYS(syscall);
++#endif
+ };
+ {
+ for (unsigned int i = 0; i < COUNTOF(scmp_sc); i++) {
diff --git a/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild b/net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild
index b303b583ef90..4a5784ca79ed 100644
--- a/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE='threads(+)'
DISTUTILS_USE_SETUPTOOLS=no
@@ -61,6 +61,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.1.8-fix-missing-scmp_sys-on-aarch64.patch"
"${FILESDIR}/${PN}-1.1.9-remove-asciidoctor-from-config.patch"
"${FILESDIR}/${PN}-1.2.0-move-newfstatat.patch"
+ "${FILESDIR}/${PN}-1.2.0-seccomp.patch"
)
WAF_BINARY="${S}/waf"