summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-09-24 10:45:06 +0800
committerYixun Lan <dlan@gentoo.org>2021-09-24 10:56:53 +0800
commita7ea1bcb61b4b22a94d1f25daf635c0965b30ea5 (patch)
tree38518429be05f97792c9a6cb70b96bcf4691e74d /net-misc/ofono
parentx11-drivers/xf86-input-libinput: Version bump to 1.2.0 (diff)
downloadgentoo-a7ea1bcb61b4b22a94d1f25daf635c0965b30ea5.tar.gz
gentoo-a7ea1bcb61b4b22a94d1f25daf635c0965b30ea5.tar.bz2
gentoo-a7ea1bcb61b4b22a94d1f25daf635c0965b30ea5.zip
net-misc/ofono: version bump, 1.33
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc/ofono')
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-1.33.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index c92a484776dd..6c678670a5d0 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -1 +1,2 @@
DIST ofono-1.31.tar.xz 1049252 BLAKE2B f7b40d3aa7854369a7886a4b64bb66044e8f016682665935f7727bf219c084d266d8fd7f80c97e58234d845f7db3dc52133298697274745d115cf14c62769d82 SHA512 377cda34dcc92d1f339a4b3271de5a14afaf309061c4467e5af18089cd821e65c0d8ad29d07e96d0f0480bb51554b284afb6bc2b9da586cc30dc0c1440612b20
+DIST ofono-1.33.tar.xz 1060408 BLAKE2B 646a96c0926ea032fef0357aabe6a4be6da88f4ccbdff59bb86b5de73a9b469362151b212a05234619f5d616b534343137c66e923782c7d50dfe13d2bf66558c SHA512 8d88226aa2b43eca840c6330045ee7a96c91f6003b06fca5ea55b74fc229f0e0ba0c8d98f7945f8c23ec5a8e7057bffef6335c61842e245686e0ed7c5feda589
diff --git a/net-misc/ofono/ofono-1.33.ebuild b/net-misc/ofono/ofono-1.33.ebuild
new file mode 100644
index 000000000000..7b3600dc6b80
--- /dev/null
+++ b/net-misc/ofono/ofono-1.33.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://01.org/ofono"
+SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.6
+ >=dev-libs/glib-2.68
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}