summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-12 15:57:10 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-12 16:14:21 +0000
commit1c409adcce61eab53a3398e9af5bd51c6fb4e953 (patch)
tree06f85fb046f50e7ff78fea0a7b9419da89ab4bfb /net-misc/oidc-agent/oidc-agent-4.0.2.ebuild
parentdev-python/ruamel-std-pathlib: tag as ALLARCH in metadata (diff)
downloadgentoo-1c409adcce61eab53a3398e9af5bd51c6fb4e953.tar.gz
gentoo-1c409adcce61eab53a3398e9af5bd51c6fb4e953.tar.bz2
gentoo-1c409adcce61eab53a3398e9af5bd51c6fb4e953.zip
net-misc/oidc-agent-4.0.2: do not autodetect liblist.so
One, no automagic. Two, this picks up the library installed by dev-libs/liblist - which is NOT the correct one. Closes: https://bugs.gentoo.org/775494 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-misc/oidc-agent/oidc-agent-4.0.2.ebuild')
-rw-r--r--net-misc/oidc-agent/oidc-agent-4.0.2.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/oidc-agent-4.0.2.ebuild b/net-misc/oidc-agent/oidc-agent-4.0.2.ebuild
index 1bac67f225cc..88d48a54d23d 100644
--- a/net-misc/oidc-agent/oidc-agent-4.0.2.ebuild
+++ b/net-misc/oidc-agent/oidc-agent-4.0.2.ebuild
@@ -25,9 +25,15 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${PN}-4.0.2_install-perms.patch
+ "${FILESDIR}"/${PN}-4.0.2_makefile-liblist-automagic.patch
"${FILESDIR}"/${PN}-4.0.2_makefile-toolchain-vars.patch
)
+src_prepare() {
+ default
+ sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
+}
+
src_compile() {
# As of 4.0.2 parallel building still doesn't work
emake -j1