summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Förster <Dessa@gmake.de>2017-05-29 13:13:26 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-15 00:05:22 +0200
commit25e131ac86f3f6ba433a4d0d01b216de8036940d (patch)
tree7ab11e37bc490749be7ce4d09fbeb1c959a926b6 /net-misc/oidentd/oidentd-2.0.8-r6.ebuild
parentmedia-video/dvgrab: fix building with GCC-6, #594548 (diff)
downloadgentoo-25e131ac86f3f6ba433a4d0d01b216de8036940d.tar.gz
gentoo-25e131ac86f3f6ba433a4d0d01b216de8036940d.tar.bz2
gentoo-25e131ac86f3f6ba433a4d0d01b216de8036940d.zip
net-misc/oidentd: bump to EAPI 6, add fedora masquerading patches
also adding a dependency on the selinux policy for this package, as well as adding myself as maintainer Closes: https://github.com/gentoo/gentoo/pull/4611 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-misc/oidentd/oidentd-2.0.8-r6.ebuild')
-rw-r--r--net-misc/oidentd/oidentd-2.0.8-r6.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/oidentd/oidentd-2.0.8-r6.ebuild b/net-misc/oidentd/oidentd-2.0.8-r6.ebuild
new file mode 100644
index 000000000000..5330a191234e
--- /dev/null
+++ b/net-misc/oidentd/oidentd-2.0.8-r6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+DESCRIPTION="Another (RFC1413 compliant) ident daemon"
+HOMEPAGE="http://ojnk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 masquerade selinux"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-oident )"
+
+DOCS=( AUTHORS ChangeLog README TODO NEWS "${FILESDIR}"/${PN}_masq.conf "${FILESDIR}"/${PN}.conf )
+
+PATCHES=(
+ "${FILESDIR}/${P}-masquerading.patch"
+ "${FILESDIR}/${P}-bind-to-ipv6-too.patch"
+ "${FILESDIR}/${P}-gcc5.patch"
+ "${FILESDIR}/${P}-log-conntrack-fails.patch"
+ "${FILESDIR}/${P}-no-conntrack-masquerading.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="~INET_TCP_DIAG"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable masquerade masq) \
+ $(use_enable masquerade nat)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.7-init ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.7-confd ${PN}
+
+ systemd_newunit "${FILESDIR}"/${PN}_at.service ${PN}@.service
+ systemd_dounit "${FILESDIR}"/${PN}.socket
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files are in /usr/share/doc/${PF}"
+ echo
+}