summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/omniORB/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/omniORB/files')
-rw-r--r--net-misc/omniORB/files/ldflags.patch11
-rw-r--r--net-misc/omniORB/files/omniNames22
-rw-r--r--net-misc/omniORB/files/omniORB-4.1.4-format-security.patch16
-rw-r--r--net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch31
4 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/omniORB/files/ldflags.patch b/net-misc/omniORB/files/ldflags.patch
new file mode 100644
index 000000000000..471df27ae7f4
--- /dev/null
+++ b/net-misc/omniORB/files/ldflags.patch
@@ -0,0 +1,11 @@
+--- mk/beforeauto.mk.in.orig 2010-04-24 21:13:17.000000000 +0200
++++ mk/beforeauto.mk.in 2010-04-24 21:14:24.000000000 +0200
+@@ -541,7 +541,7 @@
+ SharedLibraryLibNameTemplate = lib$$1$$2.$(SHAREDLIB_SUFFIX)
+ SharedLibraryImplibNameTemplate = lib$$1$$2.a
+
+-SharedLibraryPlatformLinkFlagsTemplate = -shared -Wl,-soname,$$soname
++SharedLibraryPlatformLinkFlagsTemplate = -shared -Wl,-soname,$$soname @LDFLAGS@
+
+ define SharedLibraryFullName
+ fn() { \
diff --git a/net-misc/omniORB/files/omniNames b/net-misc/omniORB/files/omniNames
new file mode 100644
index 000000000000..4f480d15b1cd
--- /dev/null
+++ b/net-misc/omniORB/files/omniNames
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting omniNames"
+ start-stop-daemon --start --background --make-pidfile --pidfile /var/run/omniNames.pid \
+ --exec /usr/bin/omniNames -- -start -always -logdir /var/log/omniORB \
+ -errlog /var/log/omniORB/omniORB.errors
+ eend $? "Error starting omniNames."
+}
+
+stop() {
+ ebegin "Stopping omniNames"
+ start-stop-daemon --stop --pidfile /var/run/omniNames.pid
+ eend $? "Error stopping omniNames."
+}
diff --git a/net-misc/omniORB/files/omniORB-4.1.4-format-security.patch b/net-misc/omniORB/files/omniORB-4.1.4-format-security.patch
new file mode 100644
index 000000000000..2af8d21d308d
--- /dev/null
+++ b/net-misc/omniORB/files/omniORB-4.1.4-format-security.patch
@@ -0,0 +1,16 @@
+ src/tool/omniidl/cxx/cccp/cccp.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tool/omniidl/cxx/cccp/cccp.c b/src/tool/omniidl/cxx/cccp/cccp.c
+index 0198b1a..64d80ae 100644
+--- a/src/tool/omniidl/cxx/cccp/cccp.c
++++ b/src/tool/omniidl/cxx/cccp/cccp.c
+@@ -8034,7 +8034,7 @@ macroexpand (hp, op)
+ else
+ parse_error = macarg (NULL_PTR, 0);
+ if (parse_error) {
+- error_with_line (line_for_error (start_line), parse_error);
++ error_with_line (line_for_error (start_line), "%s", parse_error);
+ break;
+ }
+ i++;
diff --git a/net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch b/net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch
new file mode 100644
index 000000000000..968013a25781
--- /dev/null
+++ b/net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/326791
+
+--- include/omniORB4/sslContext.h
++++ include/omniORB4/sslContext.h
+@@ -111,7 +111,11 @@
+ virtual ~sslContext();
+
+ protected:
+- virtual SSL_METHOD* set_method();
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ virtual const SSL_METHOD* set_method();
++ #else
++ virtual SSL_METHOD* set_method();
++ #endif
+ // Default to return SSLv23_method().
+
+ virtual void set_supported_versions();
+--- src/lib/omniORB/orbcore/ssl/sslContext.cc
++++ src/lib/omniORB/orbcore/ssl/sslContext.cc
+@@ -197,7 +197,11 @@
+ }
+
+ /////////////////////////////////////////////////////////////////////////
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++const SSL_METHOD*
++#else
+ SSL_METHOD*
++#endif
+ sslContext::set_method() {
+ return SSLv23_method();
+ }