summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-06-01 14:48:45 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2018-06-01 14:51:46 -0700
commit47d734b5d4acb322b1db5b57a45e59c936380b06 (patch)
treeeac9b6c8225f233e9f0f2837c080db4700720a5a /net-misc/omnisync/omnisync-1.0-r1.ebuild
parentdev-python/mysql-connector-python: Revbump for python 3.6 (diff)
downloadgentoo-47d734b5d4acb322b1db5b57a45e59c936380b06.tar.gz
gentoo-47d734b5d4acb322b1db5b57a45e59c936380b06.tar.bz2
gentoo-47d734b5d4acb322b1db5b57a45e59c936380b06.zip
net-misc/omnisync: fix bugs, allow multiple instances
Code bugs: - Fix --help display - Raise SHM unit limit - getopt loop failed to apply stats_file setting. Init improvement: - allow multiple instances. - write pidfile - declare that we use DNS (in case it starts before local resolver) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'net-misc/omnisync/omnisync-1.0-r1.ebuild')
-rw-r--r--net-misc/omnisync/omnisync-1.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/omnisync/omnisync-1.0-r1.ebuild b/net-misc/omnisync/omnisync-1.0-r1.ebuild
new file mode 100644
index 000000000000..5875550ac80f
--- /dev/null
+++ b/net-misc/omnisync/omnisync-1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A driver for NTPd for people who are firewall-challenged"
+HOMEPAGE="https://www.vanheusden.com/time/omnisync"
+LICENSE="GPL-2"
+SRC_URI="https://www.vanheusden.com/time/${PN}/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/openssl:0= net-analyzer/net-snmp:="
+DEPEND="${RDEPEND}"
+DOCS=( readme.txt Changes )
+PATCHES=(
+ "${FILESDIR}"/omnisync-1.0-help.patch
+ "${FILESDIR}"/omnisync-1.0-maxshm.patch
+ "${FILESDIR}"/omnisync-1.0-statfile.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+ sed -i \
+ -e 's/-O2 -Wall/-Wall/' \
+ -e 's/-lsnmp/-lnetsnmp/' \
+ "${S%/}/Makefile" || die
+ use debug || sed -i -e 's/$(DEBUG)//' "${S%/}/Makefile" || die
+}
+
+src_install() {
+ dosbin omnisync
+ newinitd "${FILESDIR%/}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR%/}/${PN}.confd" ${PN}
+ einstalldocs
+}
+
+pkg_postinst() {
+ local isConfigured=$(grep 'OMNISYNC_MODE=""' "${ROOT%/}/etc/conf.d/${PN}")
+ if [[ -n "${isConfigured}" ]] ; then
+ elog "Be sure to configure ${PN} in ${ROOT%/}/etc/conf.d before trying to start the service"
+ fi
+}