summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-10 21:49:29 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-10 21:49:29 -0500
commit57d3e16784676109b3f9ffd527e356e9873edda5 (patch)
tree2c85cd3702ad74b6f78f42c369448f4228ac59d1 /net-misc/openconnect
parentsys-fs/ctmg: fix manifest (diff)
downloadgentoo-57d3e16784676109b3f9ffd527e356e9873edda5.tar.gz
gentoo-57d3e16784676109b3f9ffd527e356e9873edda5.tar.bz2
gentoo-57d3e16784676109b3f9ffd527e356e9873edda5.zip
net-misc/openconnect: Cosmetic cleanup
Package-Manager: portage-2.2.26_p25
Diffstat (limited to 'net-misc/openconnect')
-rw-r--r--net-misc/openconnect/openconnect-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-misc/openconnect/openconnect-9999.ebuild b/net-misc/openconnect/openconnect-9999.ebuild
index 08beef389d47..9515779f7f30 100644
--- a/net-misc/openconnect/openconnect-9999.ebuild
+++ b/net-misc/openconnect/openconnect-9999.ebuild
@@ -7,7 +7,9 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="xml"
-if [[ "${PV}" = "9999" ]]; then
+inherit eutils java-pkg-opt-2 linux-info python-any-r1 readme.gentoo
+
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="git://git.infradead.org/users/dwmw2/${PN}.git"
inherit git-r3 autotools
else
@@ -18,8 +20,6 @@ VPNC_VER=20140806
SRC_URI="${ARCHIVE_URI}
ftp://ftp.infradead.org/pub/vpnc-scripts/vpnc-scripts-${VPNC_VER}.tar.gz"
-inherit eutils java-pkg-opt-2 linux-info python-any-r1 readme.gentoo
-
DESCRIPTION="Free client for Cisco AnyConnect SSL VPN software"
HOMEPAGE="http://www.infradead.org/openconnect.html"
@@ -69,16 +69,17 @@ pkg_setup() {
}
src_unpack() {
- if [[ ${PV} = 9999 ]]; then
+ if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
fi
unpack ${A}
}
src_prepare() {
- if [[ "${PV}" = 9999 ]]; then
+ if [[ ${PV} == 9999 ]]; then
eautoreconf
fi
+ epatch_user
}
src_configure() {