summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-01-06 09:32:18 -0600
committerJohn Helmert III <ajak@gentoo.org>2023-01-06 09:33:46 -0600
commite6b4565e4f32d431e10922941fddb71b1e464173 (patch)
tree5d12cdf74c1ebf6f504242f0eed0237219761e58 /net-misc/openvswitch
parentapp-portage/mgorny-dev-scripts: Bump to v33 (diff)
downloadgentoo-e6b4565e4f32d431e10922941fddb71b1e464173.tar.gz
gentoo-e6b4565e4f32d431e10922941fddb71b1e464173.tar.bz2
gentoo-e6b4565e4f32d431e10922941fddb71b1e464173.zip
net-misc/openvswitch: fix installation with merged-usr
Closes: https://bugs.gentoo.org/889846 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/openvswitch-2.15.0.ebuild7
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-misc/openvswitch/openvswitch-2.15.0.ebuild b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
index 83ea5328d7d0..a81e57ca0d58 100644
--- a/net-misc/openvswitch/openvswitch-2.15.0.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -90,6 +90,11 @@ src_install() {
local SCRIPT
if use monitor; then
+ # ovs-bugtool is installed to sbin by the build system, but we
+ # install it to bin below, and these clash in merged-usr
+ # https://bugs.gentoo.org/889846
+ rm "${ED}"/usr/sbin/ovs-bugtool || die
+
for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
python_foreach_impl python_doscript utilities/"${SCRIPT}"
diff --git a/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild b/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
index 963f20e12233..2029ed52fd05 100644
--- a/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -103,6 +103,11 @@ src_install() {
local SCRIPT
if use monitor; then
+ # ovs-bugtool is installed to sbin by the build system, but we
+ # install it to bin below, and these clash in merged-usr
+ # https://bugs.gentoo.org/889846
+ rm "${ED}"/usr/sbin/ovs-bugtool || die
+
for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
python_doscript utilities/"${SCRIPT}"
done