summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/pavuk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/pavuk/files')
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch26
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch10
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-pcre-fix.patch12
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch13
4 files changed, 61 insertions, 0 deletions
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch
new file mode 100644
index 000000000000..6ce18c1ed3e2
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch
@@ -0,0 +1,26 @@
+--- src/gtkmulticol.c 2009-01-21 16:37:39.000000000 +0800
++++ src/gtkmulticol.c 2012-02-21 09:47:21.680512626 +0800
+@@ -45,9 +45,9 @@
+ static void gtk_multicol_size_request(GtkWidget *widget, GtkRequisition *requisition);
+ static void gtk_multicol_size_allocate(GtkWidget *widget, GtkAllocation *allocation);
+
+-guint gtk_multicol_get_type(void)
++GType gtk_multicol_get_type(void)
+ {
+- static guint multicol_type = 0;
++ static GType multicol_type = 0;
+
+ if (!multicol_type)
+ {
+
+--- src/gtkmulticol.h 2009-01-21 16:37:40.000000000 +0800
++++ src/gtkmulticol.h 2012-02-21 09:47:42.880514545 +0800
+@@ -41,7 +41,7 @@
+ GtkBoxClass parent_class;
+ };
+
+-guint gtk_multicol_get_type(void);
++GType gtk_multicol_get_type(void);
+ GtkWidget *gtk_multicol_new(gint nrows);
+ void gtk_multicol_set_number_of_rows(GtkMultiCol *multicol, gint nrows);
+ void gtk_multicol_set_spacing(GtkMultiCol *multicol, gint hspacing, gint vspacing);
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch
new file mode 100644
index 000000000000..25338460bd4c
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch
@@ -0,0 +1,10 @@
+--- configure.in~ 2011-03-02 10:44:45.000000000 +0800
++++ configure.in 2012-02-23 09:55:28.073709216 +0800
+@@ -1749,6 +1749,7 @@
+
+ if test -n "$GTK_LIBS" ; then
+ if test -n "$GTK_LIBS"; then
++ AX_ADD_OPTION([LIBS], [$X_LIBS])
+ AX_ADD_OPTION([LIBS], [$GTK_LIBS])
+ AX_ADD_OPTION([CPPFLAGS], [$GTK_CFLAGS])
+ AC_DEFINE_UNQUOTED(GTK_FACE, [$GTK_VERSION], [with GTK+ GUI])
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-pcre-fix.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-pcre-fix.patch
new file mode 100644
index 000000000000..3d92fdd4b8b6
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-pcre-fix.patch
@@ -0,0 +1,12 @@
+--- src/re.c~ 2009-01-21 16:37:40.000000000 +0800
++++ src/re.c 2012-02-18 13:46:30.986959223 +0800
+@@ -193,8 +193,7 @@ int re_subexpr_info(re_entry *ree, int *
+ {
+ if (nr)
+ {
+- pcre_fullinfo(ree->preg, ree->preg_extra, PCRE_INFO_CAPTURECOUNT, &pmatch_nr);
+- *nr = pmatch_nr;
++ pcre_fullinfo(ree->preg, ree->preg_extra, PCRE_INFO_CAPTURECOUNT, nr);
+ }
+ }
+ #endif
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch
new file mode 100644
index 000000000000..ec3655f1468c
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/src/absio.orig.c b/src/absio.c
+index 7be9255..e19d7cd 100644
+--- a/src/absio.orig.c
++++ b/src/absio.c
+@@ -181,7 +181,7 @@ int tl_selectr(int sock, long int timeout)
+ {
+ if ((rv == 0) && !cfg.stop && !cfg.rbreak && !FD_ISSET(sock, &readfds))
+ {
+- char buf[32];
++ char buf[64];
+ int r;
+ char buf2[64];
+