summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-13 15:46:54 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-13 15:47:55 +0200
commit775540c91860c850ce01c939982f540ce1b191fb (patch)
tree47ee9054f93df1ab8c71d22641858e6a87c08715 /net-misc/pps-tools/pps-tools-1.0.1.ebuild
parentnet-analyzer/vnstat: Do not inherit versionator. (diff)
downloadgentoo-775540c91860c850ce01c939982f540ce1b191fb.tar.gz
gentoo-775540c91860c850ce01c939982f540ce1b191fb.tar.bz2
gentoo-775540c91860c850ce01c939982f540ce1b191fb.zip
net-misc/pps-tools: Bump to v1.0.1
Closes: https://bugs.gentoo.org/631760 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'net-misc/pps-tools/pps-tools-1.0.1.ebuild')
-rw-r--r--net-misc/pps-tools/pps-tools-1.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/pps-tools/pps-tools-1.0.1.ebuild b/net-misc/pps-tools/pps-tools-1.0.1.ebuild
new file mode 100644
index 000000000000..67919d79f146
--- /dev/null
+++ b/net-misc/pps-tools/pps-tools-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space tools for LinuxPPS"
+HOMEPAGE="https://github.com/redlab-i/pps-tools"
+SRC_URI="https://github.com/redlab-i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.1-build.patch
+ "${FILESDIR}"/${PN}-1.0.1-install.patch
+ "${FILESDIR}"/${PN}-1.0.1-LDFLAGS-fix.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}