summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-08 09:41:52 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-08 09:42:05 -0500
commit7f13a061f33e7ac448df4bce54c4b0f52419a52b (patch)
tree2268b4e554158f9421928ec1c8d39d02edd3b8dc /net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
parentnet-vpn/tor: version bump to 0.3.5.4_alpha (diff)
downloadgentoo-7f13a061f33e7ac448df4bce54c4b0f52419a52b.tar.gz
gentoo-7f13a061f33e7ac448df4bce54c4b0f52419a52b.tar.bz2
gentoo-7f13a061f33e7ac448df4bce54c4b0f52419a52b.zip
net-misc/proxytunnel: Take maintainership, EAPI=7 bump, add -9999
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild')
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild b/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..c3a2f9493841
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Connect stdin and stdout to a server via an HTTPS proxy"
+HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ https://proxytunnel.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ "
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-allowTLS.patch
+)
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+src_prepare() {
+ default
+ sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}" || die
+ einstalldocs
+}