summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/proxytunnel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/Manifest1
-rw-r--r--net-misc/proxytunnel/files/proxytunnel-allowTLS.patch22
-rw-r--r--net-misc/proxytunnel/metadata.xml17
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild38
4 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/proxytunnel/Manifest b/net-misc/proxytunnel/Manifest
new file mode 100644
index 000000000000..7fd7fdcb539a
--- /dev/null
+++ b/net-misc/proxytunnel/Manifest
@@ -0,0 +1 @@
+DIST proxytunnel-1.9.1.tar.gz 48025 SHA256 4a68d2c33bf53c290346b0a76e2c3d25556e954ba346be68cf65ae8f73ae8007 SHA512 819dd11bc13fc279d2d475b89909c0eea414ff71d772d4bfed742dd8d425669dc502f2c22d983bb8c58e426a2bc7209526cb21492ca5f8e92ea1b9ea961fcfdc WHIRLPOOL 5ec64622c062c45bf21275efc785ccb91bd9f61ff13b2cf40b45ea3d73edd06ef6f1b569f5e80ccd3db51a64b38601462edfe2adebf3cdf18ae34b88184a0940
diff --git a/net-misc/proxytunnel/files/proxytunnel-allowTLS.patch b/net-misc/proxytunnel/files/proxytunnel-allowTLS.patch
new file mode 100644
index 000000000000..b6865a73fc5f
--- /dev/null
+++ b/net-misc/proxytunnel/files/proxytunnel-allowTLS.patch
@@ -0,0 +1,22 @@
+From 2a26224b5ff103d2b8e2ff7be56e616d1ecde1f4 Mon Sep 17 00:00:00 2001
+From: wicher <wicher@gavagai.eu>
+Date: Sun, 26 Apr 2015 13:07:13 +0200
+Subject: [PATCH] Allow TLS
+
+---
+ ptstream.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ptstream.c b/ptstream.c
+index 4c87c80..6d55137 100644
+--- a/ptstream.c
++++ b/ptstream.c
+@@ -151,7 +151,7 @@ int stream_enable_ssl(PTSTREAM *pts) {
+
+ /* Initialise the connection */
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv3_client_method();
++ meth = SSLv23_client_method();
+ SSL_load_error_strings();
+
+ ctx = SSL_CTX_new (meth);
diff --git a/net-misc/proxytunnel/metadata.xml b/net-misc/proxytunnel/metadata.xml
new file mode 100644
index 000000000000..5fdea15e5773
--- /dev/null
+++ b/net-misc/proxytunnel/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury</name>
+ </maintainer>
+ <longdescription lang="en">
+ ProxyTunnel is a program that connects stdin and stdout to a server
+ somewhere on the network, through a standard HTTPS proxy. We mostly use
+ it to tunnel SSH sessions through HTTP(S) proxies, allowing us to do
+ many things that wouldn't be possible without ProxyTunnel.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">proxytunnel/proxytunnel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild b/net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..d6d546ccf2f4
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Connect stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
+HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ http://proxytunnel.sourceforge.net/"
+SRC_URI="https://github.com/proxytunnel/proxytunnel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/asciidoc
+ app-text/xmlto
+ "
+
+src_prepare() {
+ sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
+ epatch "${FILESDIR}"/${PN}-allowTLS.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}" || die
+ dodoc CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO
+}