summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ps3mediaserver/ps3mediaserver-1.90.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ps3mediaserver/ps3mediaserver-1.90.0.ebuild')
-rw-r--r--net-misc/ps3mediaserver/ps3mediaserver-1.90.0.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/ps3mediaserver/ps3mediaserver-1.90.0.ebuild b/net-misc/ps3mediaserver/ps3mediaserver-1.90.0.ebuild
new file mode 100644
index 000000000000..4ef99732eae5
--- /dev/null
+++ b/net-misc/ps3mediaserver/ps3mediaserver-1.90.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="DLNA compliant UPNP server for streaming media to Playstation 3"
+HOMEPAGE="http://code.google.com/p/ps3mediaserver"
+SRC_URI="mirror://sourceforge/project/ps3mediaserver/pms-${PV}-generic-linux-unix.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="multiuser +transcode tsmuxer"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6.0
+ media-libs/libmediainfo
+ media-libs/libzen
+ tsmuxer? ( media-video/tsmuxer )
+ transcode? ( media-video/mplayer[encode] )"
+
+S=${WORKDIR}/pms-${PV}
+PMS_HOME=/opt/${PN}
+
+src_prepare() {
+ if use multiuser; then
+ cat > ${PN} <<-EOF
+ #!/bin/sh
+ if [ ! -e ~/.${PN} ]; then
+ echo "Copying ${PMS_HOME} to ~/.${PN}"
+ cp -pPR "${PMS_HOME}" ~/.${PN}
+ fi
+ export PMS_HOME=\${HOME}/.${PN}
+ exec "\${PMS_HOME}/PMS.sh" "\$@"
+ EOF
+ else
+ cat > ${PN} <<-EOF
+ #!/bin/sh
+ export PMS_HOME=${PMS_HOME}
+ exec "\${PMS_HOME}/PMS.sh" "\$@"
+ EOF
+ fi
+
+ cat > ${PN}.desktop <<-EOF
+ [Desktop Entry]
+ Name=PS3 Media Server
+ GenericName=Media Server
+ Exec=${PN}
+ Icon=${PN}
+ Type=Application
+ Categories=Network;
+ EOF
+
+ unzip -j pms.jar resources/images/icon-{32,256}.png || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ exeinto ${PMS_HOME}
+ doexe PMS.sh
+
+ insinto ${PMS_HOME}
+ doins -r pms.jar *.conf documentation plugins renderers *.xml
+ use tsmuxer && dosym /opt/tsmuxer/bin/tsMuxeR ${PMS_HOME}/linux/tsMuxeR
+ dodoc CHANGELOG.txt README.md
+
+ newicon -s 32 icon-32.png ${PN}.png
+ newicon -s 256 icon-256.png ${PN}.png
+
+ domenu ${PN}.desktop
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "Don't forget to disable transcoding engines for software"
+ ewarn "that you don't have installed (such as having the VLC"
+ ewarn "transcoding engine enabled when you only have mencoder)."
+ elif use multiuser; then
+ ewarn "Remember to refresh the files in ~/.ps3mediaserver/"
+ fi
+}