summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:51:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:41 +0100
commit75dfadf03ac94e08ad2c502f893c853aab3969bf (patch)
tree9e83dc7eb8f877930b041da69e91ce98e1e6b86d /net-misc/pssh/pssh-2.3.1-r2.ebuild
parentnet-misc/charm: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-75dfadf03ac94e08ad2c502f893c853aab3969bf.tar.gz
gentoo-75dfadf03ac94e08ad2c502f893c853aab3969bf.tar.bz2
gentoo-75dfadf03ac94e08ad2c502f893c853aab3969bf.zip
net-misc/pssh: Remove duplicate setuptools dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/pssh/pssh-2.3.1-r2.ebuild')
-rw-r--r--net-misc/pssh/pssh-2.3.1-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/pssh/pssh-2.3.1-r2.ebuild b/net-misc/pssh/pssh-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..eb333cc8d3a5
--- /dev/null
+++ b/net-misc/pssh/pssh-2.3.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
+HOMEPAGE="https://code.google.com/p/parallel-ssh/"
+SRC_URI="https://parallel-ssh.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="net-misc/openssh
+ !net-misc/putty"
+DEPEND="${RDEPEND}"
+
+# Requires ssh access to run.
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ sed -i -e "s|man/man1'|share/&|g" setup.py || die
+ distutils-r1_python_prepare_all
+}