summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-11-16 10:34:36 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2020-11-16 10:34:36 -0800
commit5113e178dea7ee8a85f06c6d2853abd8324f25a7 (patch)
treec15d225ef514e3feadd52252b2f232ddf38b778d /net-misc/pssh/pssh-2.3.4-r1.ebuild
parentnet-libs/nodejs: bump to 12.19.1 and 14.15.1 (diff)
downloadgentoo-5113e178dea7ee8a85f06c6d2853abd8324f25a7.tar.gz
gentoo-5113e178dea7ee8a85f06c6d2853abd8324f25a7.tar.bz2
gentoo-5113e178dea7ee8a85f06c6d2853abd8324f25a7.zip
net-misc/pssh: re-add
Resurrect useful package from lastrites. Closes: https://bugs.gentoo.org/735426 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc/pssh/pssh-2.3.4-r1.ebuild')
-rw-r--r--net-misc/pssh/pssh-2.3.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/pssh/pssh-2.3.4-r1.ebuild b/net-misc/pssh/pssh-2.3.4-r1.ebuild
new file mode 100644
index 000000000000..08289ea07a0e
--- /dev/null
+++ b/net-misc/pssh/pssh-2.3.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
+HOMEPAGE="https://github.com/lilydjwg/pssh"
+SRC_URI="https://github.com/lilydjwg/pssh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="net-misc/openssh
+ !net-misc/putty"
+DEPEND="${RDEPEND}"
+
+# Requires ssh access to run.
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ sed -i -e "s|man/man1'|share/&|g" setup.py || die
+ distutils-r1_python_prepare_all
+}