summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-07-10 09:33:37 +0100
committerMatthew Smith <matthew@gentoo.org>2022-07-10 09:39:37 +0100
commit8885652accd863eb209ea3e4a0e4b7e92b7f02fc (patch)
treeeb8d195472dd58ef78a402aa0ab0f349baa161b8 /net-misc/putty
parentnet-misc/putty: replace 404'd src_uri (diff)
downloadgentoo-8885652accd863eb209ea3e4a0e4b7e92b7f02fc.tar.gz
gentoo-8885652accd863eb209ea3e4a0e4b7e92b7f02fc.tar.bz2
gentoo-8885652accd863eb209ea3e4a0e4b7e92b7f02fc.zip
net-misc/putty: build and install html docs
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/putty-0.77-r1.ebuild (renamed from net-misc/putty/putty-0.77.ebuild)16
-rw-r--r--net-misc/putty/putty-9999.ebuild16
2 files changed, 20 insertions, 12 deletions
diff --git a/net-misc/putty/putty-0.77.ebuild b/net-misc/putty/putty-0.77-r1.ebuild
index cec778a9b089..be3a4064accf 100644
--- a/net-misc/putty/putty-0.77.ebuild
+++ b/net-misc/putty/putty-0.77-r1.ebuild
@@ -17,7 +17,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug +gtk gtk2 ipv6 gssapi"
+IUSE="debug doc +gtk gtk2 ipv6 gssapi"
RDEPEND="
!net-misc/pssh
@@ -37,8 +37,8 @@ DEPEND="
BDEPEND="
dev-lang/perl
virtual/pkgconfig
+ doc? ( app-doc/halibut )
"
-#[[ ${PV} == *9999 ]] && BDEPEND+=" doc? ( app-doc/halibut )"
REQUIRED_USE="
gtk2? ( gtk )
@@ -60,15 +60,19 @@ src_configure() {
cmake_src_configure
}
+src_compile() {
+ cmake_src_compile all doc
+}
+
src_install() {
cmake_src_install
doman "${BUILD_DIR}"/doc/*.1
- #if use doc ; then
- # docinto html
- # dodoc "${BUILD_DIR}"/doc/html/*.html
- #fi
+ if use doc ; then
+ docinto html
+ dodoc "${BUILD_DIR}"/doc/html/*.html
+ fi
if use gtk ; then
local i
diff --git a/net-misc/putty/putty-9999.ebuild b/net-misc/putty/putty-9999.ebuild
index cec778a9b089..be3a4064accf 100644
--- a/net-misc/putty/putty-9999.ebuild
+++ b/net-misc/putty/putty-9999.ebuild
@@ -17,7 +17,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug +gtk gtk2 ipv6 gssapi"
+IUSE="debug doc +gtk gtk2 ipv6 gssapi"
RDEPEND="
!net-misc/pssh
@@ -37,8 +37,8 @@ DEPEND="
BDEPEND="
dev-lang/perl
virtual/pkgconfig
+ doc? ( app-doc/halibut )
"
-#[[ ${PV} == *9999 ]] && BDEPEND+=" doc? ( app-doc/halibut )"
REQUIRED_USE="
gtk2? ( gtk )
@@ -60,15 +60,19 @@ src_configure() {
cmake_src_configure
}
+src_compile() {
+ cmake_src_compile all doc
+}
+
src_install() {
cmake_src_install
doman "${BUILD_DIR}"/doc/*.1
- #if use doc ; then
- # docinto html
- # dodoc "${BUILD_DIR}"/doc/html/*.html
- #fi
+ if use doc ; then
+ docinto html
+ dodoc "${BUILD_DIR}"/doc/html/*.html
+ fi
if use gtk ; then
local i