summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-09-26 13:27:50 -0400
committerMike Gilbert <floppym@gentoo.org>2015-09-26 13:28:26 -0400
commit2a299cd48ccf3dbdb572172a90adb7bc56aa8969 (patch)
tree74040828977832c1bed50fc359ffbd243b3d304c /net-misc/pycnb
parentnet-misc/openvpn: ia64 stable wrt bug #556874 (diff)
downloadgentoo-2a299cd48ccf3dbdb572172a90adb7bc56aa8969.tar.gz
gentoo-2a299cd48ccf3dbdb572172a90adb7bc56aa8969.tar.bz2
gentoo-2a299cd48ccf3dbdb572172a90adb7bc56aa8969.zip
net-misc/pycnb: Fix permissions on files in ${S}
setuptools preserves these permissions when installing them. Bug: https://bugs.gentoo.org/561546 Package-Manager: portage-2.2.21_p119
Diffstat (limited to 'net-misc/pycnb')
-rw-r--r--net-misc/pycnb/pycnb-0.0.4-r1.ebuild (renamed from net-misc/pycnb/pycnb-0.0.4.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-misc/pycnb/pycnb-0.0.4.ebuild b/net-misc/pycnb/pycnb-0.0.4-r1.ebuild
index f363f1ae810a..c6468e436465 100644
--- a/net-misc/pycnb/pycnb-0.0.4.ebuild
+++ b/net-misc/pycnb/pycnb-0.0.4-r1.ebuild
@@ -20,3 +20,9 @@ DEPEND="dev-python/cement[${PYTHON_USEDEP}]
dev-python/twisted-web
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ find ${P} -type d -exec chmod 0755 {} + || die
+ find ${P} -type f -exec chmod 0644 {} + || die
+}