summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/pymazon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/pymazon')
-rw-r--r--net-misc/pymazon/Manifest2
-rw-r--r--net-misc/pymazon/files/amz.xml11
-rw-r--r--net-misc/pymazon/metadata.xml8
-rw-r--r--net-misc/pymazon/pymazon-0.9-r1.ebuild60
-rw-r--r--net-misc/pymazon/pymazon-0.9.1.ebuild60
5 files changed, 141 insertions, 0 deletions
diff --git a/net-misc/pymazon/Manifest b/net-misc/pymazon/Manifest
new file mode 100644
index 000000000000..6af6a526f446
--- /dev/null
+++ b/net-misc/pymazon/Manifest
@@ -0,0 +1,2 @@
+DIST Pymazon-0.9.1.tar.gz 286720 SHA256 c9ccd6e7f5aad1a8434fb9fec70552d397eb2aa2b01629e35fec3e75039bce2d
+DIST Pymazon-0.9.tar.gz 58435 SHA256 1f064ee8aa9882406d463244d8c0584e0348bbb91afa7ccb8352f6a8d142656c
diff --git a/net-misc/pymazon/files/amz.xml b/net-misc/pymazon/files/amz.xml
new file mode 100644
index 000000000000..8fd3a61d69ae
--- /dev/null
+++ b/net-misc/pymazon/files/amz.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="audio/x-amzxml">
+ <sub-class-of type="text/plain"/>
+ <comment>AmazonMP3 Download Queue</comment>
+ <glob pattern="*.amz"/>
+ <magic>
+ <match type="string" offset="0" value="gtBcZ7b78K" />
+ </magic>
+ </mime-type>
+</mime-info>
diff --git a/net-misc/pymazon/metadata.xml b/net-misc/pymazon/metadata.xml
new file mode 100644
index 000000000000..4f200ad3b95b
--- /dev/null
+++ b/net-misc/pymazon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="google-code">pymazon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/pymazon/pymazon-0.9-r1.ebuild b/net-misc/pymazon/pymazon-0.9-r1.ebuild
new file mode 100644
index 000000000000..76513e370923
--- /dev/null
+++ b/net-misc/pymazon/pymazon-0.9-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils distutils fdo-mime
+
+MY_P="Pymazon-${PV}"
+DESCRIPTION="Downloader for the Amazon.com MP3 music store"
+HOMEPAGE="http://code.google.com/p/pymazon/"
+SRC_URI="http://pymazon.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gtk +qt4"
+
+DEPEND="gtk? ( dev-python/pygtk )
+ qt4? ( dev-python/PyQt4 )"
+RDEPEND="${DEPEND}
+ dev-python/pycrypto"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/pixmaps
+ newins pymazon/resource/icons/download.png pymazon.png
+
+ if ! use gtk && ! use qt4; then
+ EXTRA_FIELDS="\nTerminal=true\nNoDisplay=true"
+ DEFAULTARGS=" -c"
+ fi
+ make_desktop_entry "pymazon${DEFAULTARGS}" "Pymazon MP3 Downloader" \
+ pymazon "Network;FileTransfer" \
+ "MimeType=audio/x-amzxml;${EXTRA_FIELDS}"
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/amz.xml"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "To link pymazon with your amazon.com account, visit:"
+ einfo " http://www.amazon.com/gp/dmusic/after_download_manager_install.html"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/net-misc/pymazon/pymazon-0.9.1.ebuild b/net-misc/pymazon/pymazon-0.9.1.ebuild
new file mode 100644
index 000000000000..f2e7dcb50fef
--- /dev/null
+++ b/net-misc/pymazon/pymazon-0.9.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2"
+inherit eutils distutils fdo-mime
+
+MY_P="Pymazon-${PV}"
+DESCRIPTION="Downloader for the Amazon.com MP3 music store"
+HOMEPAGE="http://code.google.com/p/pymazon/"
+SRC_URI="http://pymazon.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk +qt4"
+
+DEPEND="gtk? ( dev-python/pygtk )
+ qt4? ( dev-python/PyQt4 )"
+RDEPEND="${DEPEND}
+ dev-python/pycrypto"
+S="${WORKDIR}/pymazon"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/pixmaps
+ newins pymazon/resource/icons/download.png pymazon.png
+
+ if ! use gtk && ! use qt4; then
+ EXTRA_FIELDS="\nTerminal=true\nNoDisplay=true"
+ DEFAULTARGS=" -c"
+ fi
+ make_desktop_entry "pymazon${DEFAULTARGS}" "Pymazon MP3 Downloader" \
+ pymazon "Network;FileTransfer" \
+ "MimeType=audio/x-amzxml;${EXTRA_FIELDS}"
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/amz.xml"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "To link pymazon with your amazon.com account, visit:"
+ einfo " http://www.amazon.com/gp/dmusic/after_download_manager_install.html"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}