summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:51:36 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:42 +0100
commit929396c54defdd47ef4690885ccb7732b7228765 (patch)
treefc420fda4ece266dcdd5b00c7ebbd8d551e4bf7b /net-misc/pytvshows/pytvshows-0.2-r4.ebuild
parentnet-misc/pssh: Remove duplicate setuptools dep (diff)
downloadgentoo-929396c54defdd47ef4690885ccb7732b7228765.tar.gz
gentoo-929396c54defdd47ef4690885ccb7732b7228765.tar.bz2
gentoo-929396c54defdd47ef4690885ccb7732b7228765.zip
net-misc/pytvshows: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/pytvshows/pytvshows-0.2-r4.ebuild')
-rw-r--r--net-misc/pytvshows/pytvshows-0.2-r4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/pytvshows/pytvshows-0.2-r4.ebuild b/net-misc/pytvshows/pytvshows-0.2-r4.ebuild
new file mode 100644
index 000000000000..dd398bde85ea
--- /dev/null
+++ b/net-misc/pytvshows/pytvshows-0.2-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="downloads torrents for TV shows from RSS feeds provided by ezrss.it"
+HOMEPAGE="https://sourceforge.net/projects/pytvshows/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/feedparser[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ezrss.it.patch"
+ "${FILESDIR}/${P}-feedurl.patch"
+ "${FILESDIR}/${P}-improved-re.patch"
+ "${FILESDIR}/${P}-rename-var.patch"
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}