summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2022-03-11 17:52:12 +0300
committerSam James <sam@gentoo.org>2022-03-11 15:21:09 +0000
commit373fb9c4264a8fabcbb567c4d9a2b343873006d1 (patch)
tree0796f0cb8d7f49422c06729e48ec5e263f184a66 /net-misc/r8125
parentsys-libs/zlib: fix IncorrectCopyright (diff)
downloadgentoo-373fb9c4264a8fabcbb567c4d9a2b343873006d1.tar.gz
gentoo-373fb9c4264a8fabcbb567c4d9a2b343873006d1.tar.bz2
gentoo-373fb9c4264a8fabcbb567c4d9a2b343873006d1.zip
net-misc/r8125: new upstream version 9.008.0
Updated to the new upstream version 9.008.0. Enabled by default 'rss' and 'multi-tx-q' use flags. Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/24491 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/r8125')
-rw-r--r--net-misc/r8125/Manifest1
-rw-r--r--net-misc/r8125/r8125-9.008.00.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/r8125/Manifest b/net-misc/r8125/Manifest
index e8457bed63e4..28f0877dca1b 100644
--- a/net-misc/r8125/Manifest
+++ b/net-misc/r8125/Manifest
@@ -1 +1,2 @@
DIST r8125-9.007.01.tar.bz2 88973 BLAKE2B fda3be9bded138bb6ee6b131c4d89d2dc777153eb1d003f11803d412d28957c944f220452762ca92ebb1cbfe2d5e7bdc0f9944517a0bb58ed0f3f112986c21ee SHA512 753c328d5a962366ea1bd495ca3860309bc6ff8b2f3fb367a9f184441dd7c507d0eb4d63cc9b23851d0287e75ad2d602caee5ffed911691349cf8d0f37477a5c
+DIST r8125-9.008.00.tar.bz2 89622 BLAKE2B d1106086d1bca53484f8536072cddd506087b5d49983cbb91e921e86674c074b38c8a01cb51d2ea5793d8ffbff6e97ab05e48720ff00a805c4096a1d62a0cc30 SHA512 ff740a49fcc94b3de826f6299c489ed3f92ba9123ca2b2fe3c9035eecd16d518b6a4e6c2fa2531bb670c52097a52a0fb2fdf71b721efb20c83bb59d94d99c6c6
diff --git a/net-misc/r8125/r8125-9.008.00.ebuild b/net-misc/r8125/r8125-9.008.00.ebuild
new file mode 100644
index 000000000000..a028be892582
--- /dev/null
+++ b/net-misc/r8125/r8125-9.008.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8125 vendor driver for Realtek RTL8125 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+# The alternative direct URL for the file from the link above with description
+# "2.5G Ethernet LINUX driver r8125 for kernel up to 5.6" to avoid CAPTCHA
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8125(net:${S}/src)"
+BUILD_TARGETS="modules"
+IUSE="+multi-tx-q ptp +rss use-firmware"
+
+CONFIG_CHECK="~!R8169"
+WARNING_R8169="CONFIG_R8169 is enabled. ${PN} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ BUILD_PARAMS+=" ENABLE_PTP_SUPPORT=$(usex ptp y n)"
+ BUILD_PARAMS+=" ENABLE_RSS_SUPPORT=$(usex rss y n)"
+ BUILD_PARAMS+=" ENABLE_MULTIPLE_TX_QUEUE=$(usex multi-tx-q y n)"
+ BUILD_PARAMS+=" ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}