summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2020-06-15 14:59:55 +0300
committerThomas Deutschmann <whissi@gentoo.org>2020-06-20 22:30:50 +0200
commit051425d0b42155f08e3c5b20185e57fb0a6d8613 (patch)
treef67cc54729e5bf3185ce4608fd89a5a9c1abcf63 /net-misc/rclone/rclone-1.52.1.ebuild
parentnet-libs/libvncserver: Version bump to 0.9.13 (diff)
downloadgentoo-051425d0b42155f08e3c5b20185e57fb0a6d8613.tar.gz
gentoo-051425d0b42155f08e3c5b20185e57fb0a6d8613.tar.bz2
gentoo-051425d0b42155f08e3c5b20185e57fb0a6d8613.zip
net-misc/rclone-1.52.1 version bump
Closes: https://bugs.gentoo.org/728356 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/16250 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/rclone/rclone-1.52.1.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.52.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/rclone/rclone-1.52.1.ebuild b/net-misc/rclone/rclone-1.52.1.ebuild
new file mode 100644
index 000000000000..380576cdebc5
--- /dev/null
+++ b/net-misc/rclone/rclone-1.52.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build bash-completion-r1
+EGO_PN="github.com/rclone/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="amd64 ~arm ~arm64 x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}